Problems running PSP X4 after install

Corel Paint Shop Pro

Moderator: Kathy_9

Posts: 2
Joined: Sun Jul 01, 2018 2:38 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
ram: 16GB
Hard_Drive_Capacity: 200GB
Corel programs: PSP 2018; Painter Essentials 5
Location: Gainesville, FL USA

Problems running PSP X4 after install

Post by kjs_07 »


Problems running “vintage” Corel PSP X4.

I have a 2nd computer that has Windows 10 on it (ver 10.0.19045 Build 19045) I am wanting to run my older PSP versions on it to play around with them.

I have successfully installed Corel PSP X2 and two Jasc versions. I have not been successful with X4.

At first I wanted it on a secondary internal drive (like X2 is), but it wouldn’t work. I installed it, and it wouldn’t run. I tired Run as Administrator. I tried various things with the Compatibility troubleshooter (as if Win 7 or XP). I even uninstalled and installed onto C drive. No joy (also trying run as admin and compatibility troubleshooter again).

I have the original disc envelope with the serial number.

When I double-click the PSP X4 icon, it doesn’t even seem to do anything after a second or 2 with the blue circle (showing something is running). Blue circle is gone fast. Same if I hold down the shift key while clicking on the icon or if I try to open from Start Menu.

Not sure what to look for to solve.

Any help would be much appreciated. Not sure how X2 and earlier works fine and this won’t.
Thanks, Kimberley
User avatar
Ken Berry
Site Admin
Posts: 22413
Joined: Fri Dec 10, 2004 9:36 pm
operating_system: Windows 11
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Gigabyte B550M DS3H AC
processor: AMD Ryzen 9 5900X
ram: 32 GB DDR4
Video Card: AMD RX 6600 XT
Hard_Drive_Capacity: 1 TB SSD + 2 TB HDD
Monitor/Display Make & Model: Kogan 32" 4K 3840 x 2160
Corel programs: VS2022; PSP2023; DRAW2021; Painter 2022
Location: Levin, New Zealand

Re: Problems running PSP X4 after install

Post by Ken Berry »

Have you tried opeing Task Manager in Windows, and looking under either Apps or more likely Background Processes to see if there is an entry for Corel Paintshop Pro? If it is there, right click it and choose End Task. Then you could reboot, though you could first try PSP C4 again to see if it opens this time.
Ken Berry