Activation fails

Posts: 1
Joined: Fri Sep 29, 2017 3:51 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUS Intel B250 19 PCIe MINING
processor: Intel
ram: 12GB
Hard_Drive_Capacity: 1tb
Monitor/Display Make & Model: asus
Corel programs: PhotoImpact X3

Activation fails

Post by rtenny »

I have been using PI like forever, I have paid for all the upgrades and I have the activation codes in my account.
I have changed my Laptop and after downloading and installing X3 I tried to activate the new install.
But I now get an error about the activation server cannot be reached. I tried this in different locations (at home and at work) but it doe snot work.
I have optical fibre in the office and internet uis really fast.

Any ideas why this does not work? I have attached a screenshot
You do not have the required permissions to view the files attached to this post.
User avatar
Site Admin
Posts: 14185
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX, 19, 20, 22 PSP2023, PI, MS3D
Location: UK

Re: Activation fails

Post by lata »

Hi rtenny

And welcome to the forums.

We do not work for Corel but run the forums as volunteers.
Activations and queries regarding your serial numbers should be addressed to Corel, try their Chat Lines.
I used that option to activate one of my programs with similar problems.
Maybe a Corel server issue.

You could try running the program with your internet off, that should give you other options to activate, maybe by phone. Then again the Chat Lines may be the easiest option.

Sorry I do not have a more positive solution.