Aftershot Pro 2 Linux demo expired

AfterShot Pro General Questions & Getting Started Forum
Posts: 1
Joined: Wed Sep 03, 2014 1:03 am
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit

Aftershot Pro 2 Linux demo expired

Post by cwage »

Hey guys,

I'm trying to give aftershot pro 2 a whirl, but it says my demo is expired -- I assume because I installed an older aftershot demo long ago. Is there a way I can get this reset so I can actually give it a try?
Posts: 153
Joined: Wed Feb 15, 2012 11:29 am
operating_system: Windows XP Pro
System_Drive: C
32bit or 64bit: 32 Bit

Re: Aftershot Pro 2 Linux demo expired

Post by FalCT60 »


On winboxes, uninstall the software then in the registry delete every entry / data related to Bibble / ASP / [Corel (unless you use other softwares from them)], then do the same within the apps folder.
On linux, I don't know but maybe uninstalling the software might be enough.

Posts: 37
Joined: Mon Feb 27, 2012 6:57 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: ASRock Z77
processor: Intel i7 quad core
ram: 32 GB
Video Card: saphire hd 5450 2xdvi
sound_card: on board
Hard_Drive_Capacity: 4TB
Monitor/Display Make & Model: Eizo S2410W & S2431W, calibrated with i1d2

Re: Aftershot Pro 2 Linux demo expired

Post by TheDude »

on linux: Try to remove your ~/.AfterShotPro folder. A quick and dirty alternative is to simply create a new user.
Posts: 4
Joined: Mon Sep 10, 2018 3:46 am
operating_system: Linux
System_Drive: C

Re: Aftershot Pro 2 Linux demo expired

Post by linuxphotog »

I tried to test out AfterShot when I first set up my new Ubuntu install; something didn't work right, and by the time I got around to trying it again, the trial period was over. But I'd love to see if I can actually use AfterShot instead of relying on Darktable (they try hard but it's just so clunky) or trying to get LightRoom running in WINE or getting my photos on a network share so I can use LightRoom from Windows.

None of these worked: Removing ~/.AfterShotPro, removing /opt/AfterShot* where the install lives, using the package manager to uninstall and then re-installing from the .deb.

To figure out what to remove, I ran systrace on AfterShot, on the theory that they must be looking at some persisted file:
strace -e open,openat AfterShot3X64 2> /tmp/filelist.txt
and then looked for files they were actually able to open, knowing it had to be somewhere user-writable (~/) that is expected to be durable (not /tmp or /var).
sort < /tmp/filelist.txt | uniq | grep -v ENOENT | grep -v EACCES

I don't want to make AfterShot developers' lives too hard (by the way one of the big reasons I want to use AfterShot is to avoid all that cloud licensing annoyance Adobe has gone for) so I won't post the specific file here, but if you really do need more time to figure out if AfterShot will work for you, this should be enough info to reset the trial.