MPEG encoding and advanced settings (black level)

For VideoStudio, MediaStudio Pro, VideoGraphics Lab, Cool3D

Moderator: Ken Berry

Posts: 72
Joined: Fri Nov 11, 2005 9:55 am
operating_system: Windows 7 Ultimate
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Gigabyte G31M-ES2C
processor: 2.8Ghz DC running at 3.4GHz [on extra hormones]
ram: 2Gb
Video Card: Nvidia Geforce 9500GT [silent]
sound_card: External M-Audio Audiophile
Hard_Drive_Capacity: 1 Tb
Monitor/Display Make & Model: LG wide Flat [generic PNP]
Location: Stora Höga, 45 km north Gothenburg on the westcoast of Sweden

MPEG encoding and advanced settings (black level)

Post by Radioman62 »

Hi all

This is a new thread, stiched, clipped an paste, from my own replys from other threads.
It's time to really nail this one down, because I'm sure I'm not alone.

Black is not all black when encoded to mpeg2, making DVD's. Same as it was way back in 2005 and forward. At least on my TV set. Panasonic PAL. I these days have a new 42" flatscreen Panasonic compared to my old 4:3 "fat TV set" Sony Trinitron. The same experience.....
I want the same look, contrast and colors, as with the DV tape straight to the TV set, even if there, offcource, could be some artifacts from the encoding itself.

Here is my almost 6 years old thread on that problem.

There was a thread once, I can't find now. Seems to be erased. I have it on paper though. The subject was MPEG encoder settings in VS11+
The starter of it was Jack_HDV and replys came from vidoman, Ken Berry and etech6355.
The tip in there was to add the Advance=1 in the uvs.ini file under the subject [viodriver]. I have tried this on the new Corel VS X4 but to no sucess. The mapstructure is also a bit different in W7, users vs. document and settings.
The meaning with this added line was to get another button "advanced" under the tab "compression" and be able to change "primary colors" via a dropdown list.

Anyone remember this? Does anyone knows here how to do it in Corel VS? Is it maybe something that shouldn't be doable in VS, because of licence payment to the company Mainconcept who has done the encoder. VS should maybe only have the "light" version"?
Just before this new thread I managed to encode with an older version of Canopus Procoder v.2, with perfect result as it comes to black and white and also a bit stronger colors. It's so much easier if we could get the same result withing VS.

Anyone knows what I'm talking about?
Regards // Ove Tegnér
User avatar
Ron P.
Posts: 12002
Joined: Tue May 10, 2005 12:45 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Hewlett-Packard 2AF3 1.0
processor: 3.40 gigahertz Intel Core i7-4770
ram: 16GB
Video Card: NVIDIA GeForce GTX 645
sound_card: NVIDIA High Definition Audio
Hard_Drive_Capacity: 4TB
Monitor/Display Make & Model: 1-HP 27" IPS, 1-Sanyo 21" TV/Monitor
Corel programs: VS5,8.9,10-X5,PSP9-X8,CDGS-9,X4,Painter
Location: Kansas, USA

Re: MPEG encoding and advanced settings (black level)

Post by Ron P. »

Hey I found where Corel tried to hide the same settings of the uvs.ini file for VS X4. Those settings are now found in C:\ProgramData\Ulead Systems\Corel VideoStudio Pro\14.0\GG_App.ini. You will first need to change the permissions for that file. To do so simply right-click on the file select Properties, go to the security tab. Then highlight your user name, and click Edit, then in the next dialog, at the bottom, check the box for Allow.

Now open the GG_App.ini file, scroll down to the [VIODRIVER} section, and add the line Advance=1. You should now get the Advanced button which opens the MPEG Output dialog window.

Here's a link to Terry's information on using the MPEG Output dialog;

Video Tutorial on how to get the "Advanced Button" in VS X4
Ron Petersen, Web Board Administrator
Black Lab
Posts: 7429
Joined: Wed Dec 15, 2004 3:11 pm
operating_system: Windows 8
System_Drive: C
32bit or 64bit: 64 Bit
Location: Pottstown, Pennsylvania, USA

Re: MPEG encoding and advanced settings (black level)

Post by Black Lab »

At least on my TV set.
I think that is the key. My black is black.