Wobbly video issue

laxity

Wobbly video issue

Post by laxity »

Hi All,

I am tearing my hair out trying to get decent video output on my DVD's that I have encoded with DWS, so I hope someone can help me!

I have a selection of videos from my JVC hard drive camcorder that I have edited together using Cyberlink Powerdirector Express. The output file is mpeg2 NTSC which I have encoded at the highest bit rate I could set to retain quality (CBR 25000kbps) which created me a 35GB file.

I then loaded this into DWS and added menus and chapters etc, and then set it to output into DVD folders at a bitrate of 4900kbps VBR in DVD PAL resolution. This allows me to fit everything onto a DVD9.

But when I come to play this back I find that the video wobbles when the camera pans. I suspect that this is an interlace issue. I have applied the latest patch for DWS which contains a fix for interlace problems when encoding from NTSC -> PAL but this hasn't helped.

How can I fix this? Its driving me nuts!

Note that the wobbling shows up on a TV and when I select "deinterlace" mode when playing back the video on my PC.

The reason I have used such a high bit rate in Cyberlink Powerdirector is that on my first attempt I made the output to fit to a DVD9 but after DWS re-encoded the video again the output had a lot of mpeg artifacts visible even on the TV. So to compensate I set the output to the highest bit rate.

Can anyone help me please?

Also, is there a way to switch DWS to output to NTSC? For some reason it only lets me select PAL modes only (yes I selected PAL on install but surely I can choose somhow?)

Many thanks,
Richard.
User avatar
Ron P.
Advisor
Posts: 12002
Joined: Tue May 10, 2005 12:45 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Hewlett-Packard 2AF3 1.0
processor: 3.40 gigahertz Intel Core i7-4770
ram: 16GB
Video Card: NVIDIA GeForce GTX 645
sound_card: NVIDIA High Definition Audio
Hard_Drive_Capacity: 4TB
Monitor/Display Make & Model: 1-HP 27" IPS, 1-Sanyo 21" TV/Monitor
Corel programs: VS5,8.9,10-X5,PSP9-X8,CDGS-9,X4,Painter
Location: Kansas, USA

Post by Ron P. »

First the bald look seems to be the current "fad" for my area anyway, unless your female...;)

Is your camcorder an HD (High-def), and are you trying to record HD onto a SD disc?

The bitrate you're using is way too high for standard definition DVD. Your bitrate for the video should be between 4-8 maybe 9 Mbs. However I think that the "wobbling" is due to the field order being changed or wrong. What is the field order of your source video? DV, often mis-construed as AVI, is always Lower Field First. Analog video is most often Upper Field First. Next I will add that AVI is a container, or wrapper, that may contain any type of format, such as DivX, Xvid, or MPEG.

If your source video is DV, and while editing you have set your Project Properties to Upper Field First, then the field order has been reversed. The video editing application will change the field order of the video clip when it is rendered that that of the Project Properties set in the application.

If your intentions are to view the video on your PC, then choosing "Frame Based" or De-interlaced is fine, otherwise I would keep the field order the same as the source video.
I have applied the latest patch for DWS which contains a fix for interlace problems when encoding from NTSC -> PAL but this hasn't helped.
Are you trying to convert NTSC to PAL or vice-versa? If so good luck. About the only encoders that might do a good job of this, are very expensive, and generally used only by professional editors. The reason for this is that NTSC uses a smaller frame size than PAL, and more FPS (Frames per Second). NTSC= 720 x 480 at 29.97 fps, where PAL= 720 x 576 at 25 fps. So if you have a PAL video clip and trying to convert it to NTSC, the application will need to produce a larger frame size and invent additional frames.

With all that said, match your Project Properties to that of your Source video clips. You can of course use the highest possible bitrate, but anything over 8Mps is just waisted overhead when you're dealing with video from a camcorder (unless it's HD). You can only squeeze 4.3gig on a single layer DVD, and 9 on a Dual. Then converting PAL to NTSC is most often by luck if it works...
Ron Petersen, Web Board Administrator
laxity

Post by laxity »

Thanks for the reply.

My camcorder is standard definition and generates NTSC VOB files of size 720 x 480 at 29.97 fps.

I then load this into the software that came with the camera (Cyberlink Powerdirector Express) and then add all the multiple video files into a single edited video. I then save
this out as NTSC mpeg2 720 x 480 at 29.97 fps with CBR 25000 kb/s (to avoid loss of quality).

I then load this into DWS and create my menus etc and save the final video as a PAL DVD 720 x 576 at 25 fps. The result is a overall good quality video compressed to fit perfectly on a DVD9 but on playback I get this weird interlace wobbling on panning.

No AVI's or anything involved. Just pure mpeg all the way. The intention is to burn this to a DVD9 to play back on a TV.

I don't see any options anywhere in either of these programs to configure any kind of interlace settings. :(

Cheers,
Richard.
User avatar
Ron P.
Advisor
Posts: 12002
Joined: Tue May 10, 2005 12:45 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Hewlett-Packard 2AF3 1.0
processor: 3.40 gigahertz Intel Core i7-4770
ram: 16GB
Video Card: NVIDIA GeForce GTX 645
sound_card: NVIDIA High Definition Audio
Hard_Drive_Capacity: 4TB
Monitor/Display Make & Model: 1-HP 27" IPS, 1-Sanyo 21" TV/Monitor
Corel programs: VS5,8.9,10-X5,PSP9-X8,CDGS-9,X4,Painter
Location: Kansas, USA

Post by Ron P. »

First creating an MPEG-2 at 25Mbps does not fit the DVD compliant specs for SD. Using Dolby digital it can not exceed 9800kbps or 9.8Mps. So this is not really granting any benefits. When you create your DVD as you stated you are encoding to 4900kps, just to fit it onto a DVD-9.

You can not get any better quality then the original source. Since your camcorder is not a Hi-Def camcorder, it does not use Hi-Def bitrates, which is what you're attempting to due with 25Mbps frame rate. Lower your bitrate when you are creating your video file in Power Director. You're not gaining any better quality from a setting of 9800kbps to your 25000kbps setting.

Next the problem just may be that the conversion from NTSC>PAL just is not working in this particular situation. This is something that works sometimes, and sometimes it does not.

Since you're using "VOB" files, which are MPEG-2 with additional data, the field order may be Upper Field First. I don't use Power Director, so I'm not familiar with if and where the project settings may be, or if you can adjust them manually. However check to see that the field order of your project matches that of your "VOB" files. If your camcorder produced Upper Field first, then you need to carry that on throughout your process to the very end, meaning creating / burning your DVD. Changing that, will cause jittering, stuttering video.

I believe I read in a post in the VS forum, where a lot of PAL DVD players will play NTSC video without problems. So if you're needing to send this to someone overseas, that uses PAL, try contacting them and see if their DVD player is one of those. It may save you this type of grief for future DVDs..
Ron Petersen, Web Board Administrator
laxity

Post by laxity »

Thanks again for the reply.

Just to clarify, the only reason I am using a high bit rate when saving from Powerdirector is to avoid compression artifacts where possible. As mpeg is a lossy format each re-encode from one program to the next will cause the quality to degrade. The lower the bit rate the worse the quality drop will be. I do not intend to keep the 25Mbps bit rate, I am just using it to ensure that DWS has a good quality *intermediate* video source to work with.

I tried the lower default bitrate in Powerdirector previously and the resulting quality of the video after re-encoding through DWS was not good. With the higher quality intermediate file the final video quality at the end from DWS was much better (with the exception of the interlacing issue).

I have just tried another test with a new project and it seems that it is the conversion from NTSC -> PAL by DWS that is causing the wobbly interlace issue.

The problem I now have is, how do I convert my current PAL project in DWS into a NTSC one? Will I have to create a new project?

i.e. when you create a new project you get asked if the TV system is NTSC or PAL. I selected PAL for this project, but now I want to change it to NTSC. Any ideas?

Many thanks,
Richard.
User avatar
Ron P.
Advisor
Posts: 12002
Joined: Tue May 10, 2005 12:45 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Hewlett-Packard 2AF3 1.0
processor: 3.40 gigahertz Intel Core i7-4770
ram: 16GB
Video Card: NVIDIA GeForce GTX 645
sound_card: NVIDIA High Definition Audio
Hard_Drive_Capacity: 4TB
Monitor/Display Make & Model: 1-HP 27" IPS, 1-Sanyo 21" TV/Monitor
Corel programs: VS5,8.9,10-X5,PSP9-X8,CDGS-9,X4,Painter
Location: Kansas, USA

Post by Ron P. »

Ok, I understand your bitrate reasoning.

I'm afraid converting from NTSC to PAL and then trying to convert back to NSTC is not going correct it. You will need to start a new project. Try searching Google for ntsc to pal converter. There are some special conversion programs available..

Google Search NTSC>PAL
Ron Petersen, Web Board Administrator
Devil
Posts: 3032
Joined: Fri Mar 18, 2005 8:06 am
Location: Cyprus

reputation

Post by Devil »

Whatever you do, make sure that the conversion NTSC>PAL is done at the max quality. Converting at DVD-compliant MPEG level is always catastrophic. Canopus have a conversion software/encoder which has an excellent reputation Procoder (not the Express version), but is not given away.
[b][i][color=red]Devil[/color][/i][/b]

[size=84]P4 Core 2 Duo 2.6 GHz/Elite NVidia NF650iSLIT-A/2 Gb dual channel FSB 1333 MHz/Gainward NVidia 7300/2 x 80 Gb, 1 x 300 Gb, 1 x 200 Gb/DVCAM DRV-1000P drive/ Pan NV-DX1&-DX100/MSP8/WS2/PI11/C3D etc.[/size]
skier-hughes
Microsoft MVP
Posts: 2659
Joined: Thu Jul 21, 2005 10:09 am
operating_system: Windows 8
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: gigabyte
processor: Intel core 2 6420 2.13GHz
ram: 4GB
Video Card: NVidia GForce 8500GT
sound_card: onboard
Hard_Drive_Capacity: 36GB 2TB
Location: UK

Post by skier-hughes »

Unless I have it wrong.

You have ntsc files
You want final ouput to be ntsc.
WS for some reason won't let you choose ntsc, as you once chose PAL.

When you start a new project on the first box you name the project and choose the format type, either PAL or NTSC.

Start a new project and see if you can select NTSC.


I have always been able to change here. You cannot change it once you have started the project.