Page 1 of 1

Canon 24-105 not recognized

Posted: Sat Nov 24, 2018 2:35 pm
by mikmak
Hi
I have a Canon 24-105L lens for my Canon Camera. It is recognized if I use a crop camera such as 7D but NOT recognized if I use a 5D or 1D camera. I cannot figure out where in the lens database to correct this. I have modtified the database on several occations to add og modify lens parameters (mostly on my M4/3).

Here is the entry in the lens database - I have tried to change the 'Exif provider ID' , the 'Mount' & the 'Cropmultiplier' without any positive result.
</Lens>
<Lens raw="true" skip="false">
<Model>Canon EF 24-105mm f/4L IS</Model>
<Mount>canonSLR</Mount>
<Exif provider="Canon" id="493"/>
<FocalLength max="105" min="24"/>
<Aperture>4</Aperture>
<CropMultiplier>1.6</CropMultiplier>
<Converter factor="1" detected="false"/>
<CorrectionCoefficients>
<RadialDistortion a="0.00552" b="-0.02074" c="0" focal="24"/>
<RadialDistortion a="0.00396" b="-0.01457" c="0" focal="28"/>
<RadialDistortion a="0.00091" b="-0.00171" c="0" focal="35"/>
<RadialDistortion a="0.00077" b="0.00096" c="0" focal="50"/>
<RadialDistortion a="0.0016" b="0.0005" c="0" focal="70"/>
<RadialDistortion a="0.00467" b="-0.00624" c="0" focal="88"/>
<RadialDistortion a="0.00797" b="-0.01307" c="0" focal="105"/>
</CorrectionCoefficients>

Any ideas ??
/Per

Re: Canon 24-105 not recognized

Posted: Sat Nov 24, 2018 6:15 pm
by mikmak
Spend hours to figure this out, and the solution showed to be VERY simple..................................

When ASP shows an uncalibrated lens or don't show it at all - and you know for sure it is in the lens database THEN load the database in the lens correction plugin. Then it all works with the corections you have made.

Regards
Per