Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Bugs & Suggestions
ubuntuuser
Posts: 14
Joined: Mon Dec 16, 2013 12:27 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit

Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by ubuntuuser »

After reading http://ubuntuforums.org/showthread.php?t=2183444 I found out, that ia32-libs was removed since Ubuntu 13.10 (a developer version), which is needed by Aftershot Pro. Therefore Aftershot Pro cannot be installed with Ubuntu 14.04 Trusty Tahr, the latest LTS-Version of Ubuntu.

Does anyone know, when a new ASP-version can be expected, which works with Trusty? Does Corel know this? They should have acted sind 13.10 is out.
ge_ka
Posts: 6
Joined: Sat Jul 20, 2013 10:10 am
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by ge_ka »

hello,

try this :

http://forum.corel.com/EN/viewtopic.php ... 19#p280519

it's works on a Debian Jessie,

ge_ka
afx
Moderator
Posts: 1675
Joined: Thu Jan 12, 2012 1:38 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
Video Card: FirePro 4900
Monitor/Display Make & Model: NEC PA301w, ColorMunki
Location: München
Contact:

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by afx »

Do not install the pseudo 64bit version but the 32bit version. Works here.

cheers
afx
Send bugs to the Monkey // AfterShot Kickstart Guide // sRGB clipping sucks and Adobe RGB is just as bad
Bibble since 2005 // W7 64 on quad Phenom // Ubuntu 14.4 on quad i7 and dualcore AMD // Images
Kneops
Posts: 212
Joined: Fri May 09, 2014 2:43 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: ASUS P8 Z68
processor: Intel i7 2600
ram: 16GB
Video Card: nVidia 450
sound_card: onboard
Hard_Drive_Capacity: 14 TB
Monitor/Display Make & Model: Dell U2713H & Spider4
Corel programs: ASP3
Contact:

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by Kneops »

As I'm going to be a new user/client of AS, I hope the new version will be able to run on 64 Linux. At this moment I'm running a trial version from within Wine, because that runs better than the native version.
afx
Moderator
Posts: 1675
Joined: Thu Jan 12, 2012 1:38 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
Video Card: FirePro 4900
Monitor/Display Make & Model: NEC PA301w, ColorMunki
Location: München
Contact:

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by afx »

What runs better in Wine?
Curious...

cheers
afx
Send bugs to the Monkey // AfterShot Kickstart Guide // sRGB clipping sucks and Adobe RGB is just as bad
Bibble since 2005 // W7 64 on quad Phenom // Ubuntu 14.4 on quad i7 and dualcore AMD // Images
Grechary
Posts: 1
Joined: Sat May 10, 2014 4:26 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: LENOVO 2349KAG
processor: Intel Core i7-3520M CPU 2.90GHz
ram: 8GB
Video Card: Intel Ivybridge Mobile
sound_card: 7 Series C210 Series Chipset Family High Definitio
Hard_Drive_Capacity: 580GB
Monitor/Display Make & Model: GF108M [NVS 5400M]

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by Grechary »

Since release 13.10, Ubuntu doesnt support anymore the package ia32-libs.
On the other hand, Corel doesn't integrate this change : AfterShot is always looking for this package.

Here is a solution to set up AfterShot on Ubuntu 13.10 and 14.04.
Take in consideration, it is always better to use the Ubuntu Long Term Support release (like Ubuntu 12.04 or 14.04).

Anyway, to set up AfterShot we will add a former repository which includes ia32-libs.
But It is not recommanded to use a former repository. So after the installation, don't forget to unselect this repository.

You will start the followings commands into the terminal, with administration password.

# creat working directory
mkdir ~/tmp-AFS
cd ~/tmp-AFS

sudo -i
apt-get -f install
# c'est parti !
add-apt-repository -y "deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse"
apt-get update
apt-get -y install ia32-libs

# get AfterShot and then install it
wget http://www.corel.com/.../Patches/1_1/Af ... _amd64.deb

sudo dpkg -i AfterShotPro_amd64.deb

Now you should unselect the old repository :
=> run the Update application
=> select Others sources ('Autres logiciels' in french)
=> search, find and unselect Precise repositories

That's all ! Have fun !!
afx
Moderator
Posts: 1675
Joined: Thu Jan 12, 2012 1:38 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
Video Card: FirePro 4900
Monitor/Display Make & Model: NEC PA301w, ColorMunki
Location: München
Contact:

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by afx »

Why bother installing the 64bit package?
AS is 32bit anyway.
So just install the 32bit package now that 64bit Ubuntu no longer needs silly workarounds.

cheers
afx
Send bugs to the Monkey // AfterShot Kickstart Guide // sRGB clipping sucks and Adobe RGB is just as bad
Bibble since 2005 // W7 64 on quad Phenom // Ubuntu 14.4 on quad i7 and dualcore AMD // Images
txoni
Posts: 29
Joined: Mon Sep 09, 2013 10:05 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by txoni »

afx wrote:Why bother installing the 64bit package?
AS is 32bit anyway.
So just install the 32bit package now that 64bit Ubuntu no longer needs silly workarounds.

cheers
afx

Funny that you post that now that they released real 64 bit binaries ;-)
afx
Moderator
Posts: 1675
Joined: Thu Jan 12, 2012 1:38 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
Video Card: FirePro 4900
Monitor/Display Make & Model: NEC PA301w, ColorMunki
Location: München
Contact:

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by afx »

txoni wrote:
afx wrote:Why bother installing the 64bit package?
AS is 32bit anyway.
So just install the 32bit package now that 64bit Ubuntu no longer needs silly workarounds.
Funny that you post that now that they released real 64 bit binaries ;-)
I posted that before the release.
And there is still no good reason to use the 64bit version.

cheers
afx
Send bugs to the Monkey // AfterShot Kickstart Guide // sRGB clipping sucks and Adobe RGB is just as bad
Bibble since 2005 // W7 64 on quad Phenom // Ubuntu 14.4 on quad i7 and dualcore AMD // Images
rag2
Posts: 2
Joined: Mon Dec 09, 2013 12:16 am
operating_system: Linux
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Acer Revo
processor: Intel Core i3-2377M
ram: 4GB
Video Card: Intel Sandybridge Mobile
sound_card: V-DACII
Hard_Drive_Capacity: 742GB
Monitor/Display Make & Model: Samsung BX2331

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by rag2 »

afx wrote:And there is still no good reason to use the 64bit version.
Ah, but there is. Specifically, 64 bit OSes allow one to use more than 4GB of memory. With ASP2 allowing images up to 250Mpixels, that's about 1GB for 3 colour channels plus an alpha, or 2GB for 16bit channel depth. It won't be long before 4GB of RAM gets used up with complex processing!

In an installation with more than one machine, there are sound reasons for moving as many installations as possible to 64 bit.

YMMV, of course!
josephlin
Corel
Posts: 139
Joined: Mon Jul 12, 2010 2:44 am
operating_system: Windows 7 Ultimate
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Intel 6 series_C200
processor: Inte i5-2500k
ram: 4GB
Video Card: nVidia GTX 550i
sound_card: Singmatel
Hard_Drive_Capacity: 1TB

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by josephlin »

Hi There, I assume here the ASP version that you are talking about should be ASP1 amd64.deb version, right? Actually ASP2 amd64.deb version already remove ia32.lib of independency thus this kind of issue should not happen with 13.10 or newer version again. Here is another solution can help you to install ASP1 amd64.deb version into Ubuntu 13.10 or newer version. Just for your reference. :D


https://bugs.launchpad.net/ubuntu/+sour ... ug/1241327 Ubuntu removed it.

Here is our solution, we did it in Ubuntu 13.10 Desktop version:

1. download "AfterShotPro_amd64.deb to "Downloads" folder.

2. Launch "Files" (file organizer), find "Downloads" folder and the file you just download.

3. Right click on "AfterShotPro_amd64.deb", choose "Extract here". You should find a new folder named as "AfterShotPro_amd64"

4. Click into "AfterShotPro_amd64\DEBIAN" folder, you can find a file "control"

5. edit this file with any text editor.

6. In this "control" file, you should find somethings like

Depends: ........ ia32-libs

7. remove ia32-libs from this file. and save it.

8. rename "AfterShotPro_amd64.deb" to a new name.

9. open a terminal

10. in terminal, change current folder to "Downloads", then enter command "dpkg -b AfterShotPro_amd64". Wait for a while, you will get a new AfterShotPro_amd64.deb

11. install AftershotPro with this new deb file. Ubuntu 13.10 will complain the quality of this package is not good, continue to install.

12 .in case Ubuntu still complains about dependency error. in step 7, try to remove everything in Depends section (that is from "Depends:" to the end of "ia32-libs"). then follow all other steps.
that is because those are not available in repository. Also, in this case, users may need to install those dependency package manually. that is for those libraries listed in "Depends" (except ia32-libs), you needs to run "sudo apt-get install [library-name]"

Cheers
Joseph Lin
Product Manager, Corel PaintShop Pro / AfterShot Pro
cascagrossa
Posts: 1
Joined: Tue Jun 10, 2014 1:43 am
operating_system: Linux
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Dell Vostro 3510
processor: intel core I5
ram: 4GB
Video Card: Nvidia 310M
sound_card: onboard
Hard_Drive_Capacity: 500GB
Monitor/Display Make & Model: Dell Vostro 15.6pol - 1366x768

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by cascagrossa »

This was tested Kubuntu 14:04 - 64 bits, fresh install and up to date.

After a lot off research, I came to a procedure that works without the need for radical changes:

1. The Go Synaptics and install "lib32z1" package,
2. At the terminal go to the "/ lib32" folder
3. Execute "sudo ln-s / usr/lib32/libz1.so.1.2.8 libz.so.1"
4. Execute "sudo ln-s / usr/lib32/libz1.so.1.2.8 libz.so.1.2.8"
5. At the terminal go to the folder where you dowloaded AfterShot 64bit.
6. Execute "dpkg -i AfterShotPro2_2.0.0.133_amd64.deb".

All done! ASP will install and run smoothly ...
buntu
Posts: 20
Joined: Tue Apr 03, 2012 5:19 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: Asrock
processor: X270
ram: 8GB
Video Card: GF210
sound_card: SBx00 Azalia
Hard_Drive_Capacity: 5GB
Monitor/Display Make & Model: Viewsonic, HP

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by buntu »

I fail to install the 32bit package with Ubuntu Trusty. What can I do? I don't want to buy ASP again because of this, if I cannot get i work, I will change to http://www.darktable.org/

Code: Select all

cat /etc/issue
Ubuntu 14.04.1 LTS \n \l

Code: Select all

# dpkg -i aftershotpro2_2.0.0.133_i386.deb
Vormals nicht ausgewähltes Paket aftershotpro2 wird gewählt.
(Lese Datenbank ... 415237 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von aftershotpro2_2.0.0.133_i386.deb ...
Entpacken von aftershotpro2 (174:2.0.0.133) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von aftershotpro2:
 aftershotpro2 hängt ab von libc6.
 aftershotpro2 hängt ab von libxcursor1.
 aftershotpro2 hängt ab von libxext6.
 aftershotpro2 hängt ab von libxau6.
 aftershotpro2 hängt ab von libxdmcp6.
 aftershotpro2 hängt ab von libxrender1.
 aftershotpro2 hängt ab von libxrandr2.
 aftershotpro2 hängt ab von libfreetype6.
 aftershotpro2 hängt ab von libfontconfig1.
 aftershotpro2 hängt ab von libexpat1.
 aftershotpro2 hängt ab von libz1.
 aftershotpro2 hängt ab von libpng12-0.
 aftershotpro2 hängt ab von libsm6.
 aftershotpro2 hängt ab von libice6.
 aftershotpro2 hängt ab von libxi6.
 aftershotpro2 hängt ab von libglib2.0-0.
 aftershotpro2 hängt ab von libgcc1.
 aftershotpro2 hängt ab von zlib1g.
 aftershotpro2 hängt ab von libgl1-mesa-glx.
 aftershotpro2 hängt ab von libglu1-mesa.

dpkg: Fehler beim Bearbeiten des Paketes aftershotpro2 (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für shared-mime-info (1.2-0ubuntu3) werden verarbeitet ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Trigger für gnome-menus (3.10.1-0ubuntu2) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu1) werden verarbeitet ...
Trigger für mime-support (3.54ubuntu1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 aftershotpro2
I use Aftershot with http://xubuntu.org/
buntu
Posts: 20
Joined: Tue Apr 03, 2012 5:19 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: Asrock
processor: X270
ram: 8GB
Video Card: GF210
sound_card: SBx00 Azalia
Hard_Drive_Capacity: 5GB
Monitor/Display Make & Model: Viewsonic, HP

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by buntu »

cascagrossa wrote:This was tested Kubuntu 14:04 - 64 bits, fresh install and up to date.

After a lot off research, I came to a procedure that works without the need for radical changes:

1. The Go Synaptics and install "lib32z1" package,
2. At the terminal go to the "/ lib32" folder
3. Execute "sudo ln-s / usr/lib32/libz1.so.1.2.8 libz.so.1"
4. Execute "sudo ln-s / usr/lib32/libz1.so.1.2.8 libz.so.1.2.8"
5. At the terminal go to the folder where you dowloaded AfterShot 64bit.
6. Execute "dpkg -i AfterShotPro2_2.0.0.133_amd64.deb".

All done! ASP will install and run smoothly ...
I don't understand what you mean with the "/ lib32" folder? What do you mean with the blank after /

I tried this following your advice:

Code: Select all

dpkg -l | grep lib32z1
ii  lib32z1	1:1.2.8.dfsg-1ubuntu1	amd64	compression library - 32 bit runtime
ii  lib32z1-dev	1:1.2.8.dfsg-1ubuntu1	amd64	compression library - 32 bit development

Code: Select all

ls -la /lib32/libz*
lrwxrwxrwx 1 root root 24 Jul 27 16:19 /lib32/libz.so.1 -> /usr/lib32/libz.so.1.2.8
lrwxrwxrwx 1 root root 24 Jul 27 16:19 /lib32/libz.so.1.2.8 -> /usr/lib32/libz.so.1.2.8
Since I tried the 32bit version before, which didn't work, I executed:

Code: Select all

dpkg -P aftershotpro2
Then I tried:

Code: Select all

aftershot_pro_update_1.2.0.7# dpkg -i aftershotpro_amd64.deb
Vormals nicht ausgewähltes Paket aftershotpro wird gewählt.
(Lese Datenbank ... 415237 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von aftershotpro_amd64.deb ...
Entpacken von aftershotpro (174:1.2.0.7) ...
dpkg: Abhängigkeitsprobleme verhindern Konfiguration von aftershotpro:
 aftershotpro hängt ab von ia32-libs; aber:
  Paket ia32-libs ist nicht installiert.

dpkg: Fehler beim Bearbeiten des Paketes aftershotpro (--install):
 Abhängigkeitsprobleme - verbleibt unkonfiguriert
Trigger für shared-mime-info (1.2-0ubuntu3) werden verarbeitet ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Trigger für gnome-menus (3.10.1-0ubuntu2) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu1) werden verarbeitet ...
Trigger für mime-support (3.54ubuntu1) werden verarbeitet ...
Fehler traten auf beim Bearbeiten von:
 aftershotpro
I use Aftershot with http://xubuntu.org/
buntu
Posts: 20
Joined: Tue Apr 03, 2012 5:19 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: Asrock
processor: X270
ram: 8GB
Video Card: GF210
sound_card: SBx00 Azalia
Hard_Drive_Capacity: 5GB
Monitor/Display Make & Model: Viewsonic, HP

Re: Ubuntu 14.04 TRUSTY Tahr: Aftershot Pro NOT INSTALLABLE

Post by buntu »

josephlin wrote:Hi There, I assume here the ASP version that you are talking about should be ASP1 amd64.deb version, right? Actually ASP2 amd64.deb version already remove ia32.lib of independency thus this kind of issue should not happen with 13.10 or newer version again. Here is another solution can help you to install ASP1 amd64.deb version into Ubuntu 13.10 or newer version. Just for your reference. :D


https://bugs.launchpad.net/ubuntu/+sour ... ug/1241327 Ubuntu removed it.

Here is our solution, we did it in Ubuntu 13.10 Desktop version:

1. download "AfterShotPro_amd64.deb to "Downloads" folder.

2. Launch "Files" (file organizer), find "Downloads" folder and the file you just download.

3. Right click on "AfterShotPro_amd64.deb", choose "Extract here". You should find a new folder named as "AfterShotPro_amd64"

4. Click into "AfterShotPro_amd64\DEBIAN" folder, you can find a file "control"

5. edit this file with any text editor.

6. In this "control" file, you should find somethings like

Depends: ........ ia32-libs

7. remove ia32-libs from this file. and save it.

8. rename "AfterShotPro_amd64.deb" to a new name.

9. open a terminal

10. in terminal, change current folder to "Downloads", then enter command "dpkg -b AfterShotPro_amd64". Wait for a while, you will get a new AfterShotPro_amd64.deb

11. install AftershotPro with this new deb file. Ubuntu 13.10 will complain the quality of this package is not good, continue to install.

12 .in case Ubuntu still complains about dependency error. in step 7, try to remove everything in Depends section (that is from "Depends:" to the end of "ia32-libs"). then follow all other steps.
that is because those are not available in repository. Also, in this case, users may need to install those dependency package manually. that is for those libraries listed in "Depends" (except ia32-libs), you needs to run "sudo apt-get install [library-name]"
This was my 3rd attempt:

My 1st problem with this suggestion was that it was extracted with lower letters, so I had to rename it to AfterShotPro_amd64

Then I removed my previous installation:

Code: Select all

dpkg -P aftershotpro
You see ia32-libs is removed:
AfterShotPro_amd64/DEBIAN/control

Code: Select all

Package: aftershotpro
Version: 174:1.2.0.7
Section: graphics
Priority: optional
Architecture: amd64
Essential: no
Depends: libc6, libxcursor1, libxext6, libxau6, libxdmcp6,  libxrender1, libxrandr2, libfreetype6, libfontconfig1, libexpat1, libz1, libpng12-0, libsm6, libice6, libxi6, libglib2.0-0, libgcc1, zlib1g, libgl1-mesa-glx, libglu1-mesa
Pre-Depends:
Recommends:  
Breaks: 
Suggests: 
Installed-Size: 130904
Maintainer: Corel Corporation <support@corel.com>
Provides: 
Description: Corel AfterShot Pro
 Get professional quality, quickly and easily. Manage and edit all of your digital photographs in Corel AfterShot Pro with amazing speed in a workflow tuned to your working style, with power and editing control offered in no other application.


I didn't see any errors during installation:

Code: Select all

dpkg -i AfterShotPro_amd64_trusty.deb
Vormals nicht ausgewähltes Paket aftershotpro wird gewählt.
(Lese Datenbank ... 415237 Dateien und Verzeichnisse sind derzeit installiert.)
Vorbereitung zum Entpacken von AfterShotPro_amd64_trusty.deb ...
Entpacken von aftershotpro (174:1.2.0.7) ...
aftershotpro (174:1.2.0.7) wird eingerichtet ...
Trigger für shared-mime-info (1.2-0ubuntu3) werden verarbeitet ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Trigger für gnome-menus (3.10.1-0ubuntu2) werden verarbeitet ...
Trigger für desktop-file-utils (0.22-1ubuntu1) werden verarbeitet ...
Trigger für mime-support (3.54ubuntu1) werden verarbeitet ...

But then AfterShotPro doesn't start:

Code: Select all

AfterShotPro 
Install Path:           /opt/AfterShotPro
LD_PATH:                /opt/AfterShotPro/lib:
XLIB_SKIP_ARGB_VISUALS: 1
./AfterShotPro: error while loading shared libraries: libXrender.so.1: cannot open shared object file: No such file or directory
So I copied from my Precise-Installation the following files:

Code: Select all

cp /PRECISE/usr/lib/i386-linux-gnu/libXrender.so.1 /usr/lib32
cp /PRECISE/usr/lib/i386-linux-gnu/libfontconfig.so.1 /usr/lib32
cp /PRECISE/usr/lib/i386-linux-gnu/libfreetype.so.6 /usr/lib32
cp /PRECISE/usr/lib/i386-linux-gnu/libXext.so.6 /usr/lib32
cp /PRECISE/usr/lib/i386-linux-gnu/libX11.so.6 /usr/lib32 
cp /PRECISE/lib/i386-linux-gnu/libexpat.so.1 /usr/lib32
cp /PRECISE/usr/lib/i386-linux-gnu/libxcb.so.1 /usr/lib32 
cp /PRECISE/usr/lib/i386-linux-gnu/libXau.so.6 /usr/lib32  
cp /PRECISE/usr/lib/i386-linux-gnu/libXdmcp.so.6 /usr/lib32
Now it starts until I see the message with the "trial version", but there are still errors:

Code: Select all

~$ AfterShotPro 
Install Path:           /opt/AfterShotPro
LD_PATH:                /opt/AfterShotPro/lib:
XLIB_SKIP_ARGB_VISUALS: 1
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number
0.0: I have SSE2
0.2: Bibble program arguments ("./AfterShotPro") 
0.2: Loaded  "/opt/AfterShotPro/supportfiles/locale/aftershot_de.qm" 
0.2: Loaded  "/opt/AfterShotPro/supportfiles/locale/qt_de.qm" 
0.2: Loading plugins
I use Aftershot with http://xubuntu.org/
Post Reply