How do I disable OpenCL in AfterShot Pro 2?

AfterShot Pro General Questions & Getting Started Forum
Post Reply
msad
Posts: 4
Joined: Tue May 10, 2016 11:11 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Dell Inc. 00HFXN A00
processor: 2.60 gigahertz Intel Core i7-4510U
ram: 8074 MB
Video Card: AMD Radeon R7 M265
sound_card: On Board
Hard_Drive_Capacity: NEWARK
Monitor/Display Make & Model: Generic PnP Monitor (13.9"vis, January 2013)
Corel programs: After Shot Pro2.4

How do I disable OpenCL in AfterShot Pro 2?

Post by msad »

I know the intended way to disable OpenCL...
http://product.corel.com/help/AfterShot ... tions.html

But I can't get AfterShot Pro to launch at the moment, so I can't get into the GUI, to disable OpenCL. I've looked though all of AfterShot Pro 2 system files and I can't find anything. Does anyone know where I should be looking? Or if there is some other way to disable OpenCL.

I'm running on WIndows10.

Thanks!
cutabovehost
Posts: 2
Joined: Fri Jan 13, 2017 6:08 am
operating_system: Windows 8.1
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Gigabyte Technology Co. Ltd. Z97X-UD3H-CF
processor: 4.00 gigahertz Intel Core i7-4790K
ram: 8GB
Video Card: AMD Radeon R5 220 Intel HD Graphics 4600
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 960GB
Monitor/Display Make & Model: HP 27xi [Monitor] (27.2"vis, )
Corel programs: Corel Videostudio X9 Ultimate

Re: How do I disable OpenCL in AfterShot Pro 2?

Post by cutabovehost »

I am running AfterShot Pro 3 and having the same issue, I enabled OpenCL now when it starts the program crashes before it gets fully launched. Did you find a solution?
msad
Posts: 4
Joined: Tue May 10, 2016 11:11 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Dell Inc. 00HFXN A00
processor: 2.60 gigahertz Intel Core i7-4510U
ram: 8074 MB
Video Card: AMD Radeon R7 M265
sound_card: On Board
Hard_Drive_Capacity: NEWARK
Monitor/Display Make & Model: Generic PnP Monitor (13.9"vis, January 2013)
Corel programs: After Shot Pro2.4

Re: How do I disable OpenCL in AfterShot Pro 2?

Post by msad »

Sort of. I wasn't able to disable OpenCL without successfully launching AfterShot pro, but I did get AfterShot Pro to launch.

My aftershotpro.log file was always ending on the following line:
device: 0x[varying memory location] "Iceland"

It turns out "Iceland" is an internal code name for AMD video adapters. Once I went into Device Manager and disabled my AMD card ASP worked fine. And when I went to the OpenCL settings, they now show disabled (maybe because there is no hardware to run on so they moved themselves, I don't really know).

I put more information on this post:
http://forum.corel.com/EN/viewtopic.php ... 13#p326213
Post Reply