Updating to 2.2 on Ubuntu but won't start with 'old' setting

AfterShot Pro General Questions & Getting Started Forum
Kneops
Posts: 212
Joined: Fri May 09, 2014 2:43 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: ASUS P8 Z68
processor: Intel i7 2600
ram: 16GB
Video Card: nVidia 450
sound_card: onboard
Hard_Drive_Capacity: 14 TB
Monitor/Display Make & Model: Dell U2713H & Spider4
Corel programs: ASP3
Contact:

Updating to 2.2 on Ubuntu but won't start with 'old' setting

Post by Kneops »

I put this question in the wrong topic (the one with the release info), so I'm starting a new topic...

I installed the new version, but when I start it, it first asks me where to put the files. So I set the location to the folders I'm already using, but then ASP won't start.
When I choose a different folder then my already existing .AfterShotPro folder, namely .AfterShot folder, it will start, but then I loose all my settings and catalogs. When I set my catalog folder to the existing one, it creates a new empty one inside the old one.

I tried copying all of the contents of the old settingsfolder to the new folder, but then ASP again won't start.
macr237
Posts: 38
Joined: Sat May 26, 2012 2:43 am
operating_system: Linux
System_Drive: C
32bit or 64bit: 64 Bit
ram: 4GB
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by macr237 »

Kneops wrote:I put this question in the wrong topic (the one with the release info), so I'm starting a new topic...

I installed the new version, but when I start it, it first asks me where to put the files. So I set the location to the folders I'm already using, but then ASP won't start.
When I choose a different folder then my already existing .AfterShotPro folder, namely .AfterShot folder, it will start, but then I loose all my settings and catalogs. When I set my catalog folder to the existing one, it creates a new empty one inside the old one.
I was having the same issues. I think I may have solved it.

I have used the new catalogs and have tried File-> Open Catalog and then have found the 2014 catalog. It has now added it to the 2015 catalog. I am not sure if that is what you are trying to achieve.
Macr

:arrow: Visit my Flickr page.
macr237
Posts: 38
Joined: Sat May 26, 2012 2:43 am
operating_system: Linux
System_Drive: C
32bit or 64bit: 64 Bit
ram: 4GB
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by macr237 »

Hmm, maybe I haven't as it will no longer open.

Back to the drawing board.
Macr

:arrow: Visit my Flickr page.
macr237
Posts: 38
Joined: Sat May 26, 2012 2:43 am
operating_system: Linux
System_Drive: C
32bit or 64bit: 64 Bit
ram: 4GB
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by macr237 »

Anyone know where the config files would be hidden? I can no longer open ASP, I have removed completely, reinstalled and even have tried a full shut down, but I cannot get it to start.
Macr

:arrow: Visit my Flickr page.
afx
Moderator
Posts: 1675
Joined: Thu Jan 12, 2012 1:38 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
Video Card: FirePro 4900
Monitor/Display Make & Model: NEC PA301w, ColorMunki
Location: München
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by afx »

macr237 wrote:Anyone know where the config files would be hidden? I can no longer open ASP, I have removed completely, reinstalled and even have tried a full shut down, but I cannot get it to start.
Re-install rarely fixes anything...

Have a look at

Code: Select all

~/.config/Corel/AfterShot\ Pro\ v2.conf
And

Code: Select all

~/.AfterShot*

cheers
afx
Send bugs to the Monkey // AfterShot Kickstart Guide // sRGB clipping sucks and Adobe RGB is just as bad
Bibble since 2005 // W7 64 on quad Phenom // Ubuntu 14.4 on quad i7 and dualcore AMD // Images
Kneops
Posts: 212
Joined: Fri May 09, 2014 2:43 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: ASUS P8 Z68
processor: Intel i7 2600
ram: 16GB
Video Card: nVidia 450
sound_card: onboard
Hard_Drive_Capacity: 14 TB
Monitor/Display Make & Model: Dell U2713H & Spider4
Corel programs: ASP3
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by Kneops »

I opened the .config... file and the settings are the same as when using the option to choose the folders at startup:

.AfterShot
catalogfolder: home/jack/FotoArchiefASP

But as you can see, it only creates a subfolder in that folder and I still can't access my catalogs. I don't want them inside this newly created folder.

http://i.imgur.com/R7YIrsg.png

These are the current settings in the config file for ASP Pro 2: http://i.imgur.com/OowUthq.png
baldrick777
Posts: 31
Joined: Thu Jan 22, 2015 9:46 am
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
processor: i3 Core
ram: 4GB
Hard_Drive_Capacity: 320gB +ext
Monitor/Display Make & Model: Laptop + Samsung 22" ToC
Location: Whakatane, NZ

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by baldrick777 »

It's a bug.

Seems the new version for Linux wasn't tested well enough before release. Best to delete all ASP config files and then completely remove ASP2.2. Once done, re-install v2.1 again. You should now be good to go. You'll also need to re-install any plugins you have previously. You shouldn't need to touch the catalogue folder.

Hopefully, the devs will be quick to release a patch to overcome this glaring oversight, then we can happily re-install 2.2.
Using Linux Mint 17.1 > gThumb Viewer > ASP2 (ProPhoto RGB) > Gimp 2.9 (dev). Specialising in landscapes, concerts and portraiture.
andreas
Posts: 154
Joined: Thu Jan 12, 2012 1:53 pm
operating_system: Linux
System_Drive: X
32bit or 64bit: 64 Bit
motherboard: Asus in Workstation and Dell XPS Notebook
processor: i7-980 and i7-2720QM
ram: 12GB - 8GB
Video Card: ATI FireGL
sound_card: on board
Hard_Drive_Capacity: 4.5TB Rd10
Monitor/Display Make & Model: Samsung Syncmaster 2343sw
Location: DE - Wermelskirchen
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by andreas »

please post the Log located in .Aftershot* folder.

Andreas
Linux - not Windows
Kneops
Posts: 212
Joined: Fri May 09, 2014 2:43 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: ASUS P8 Z68
processor: Intel i7 2600
ram: 16GB
Video Card: nVidia 450
sound_card: onboard
Hard_Drive_Capacity: 14 TB
Monitor/Display Make & Model: Dell U2713H & Spider4
Corel programs: ASP3
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by Kneops »

See attachment for the log file.
Attachments
AfterShotPro.log
(123.26 KiB) Downloaded 256 times
andreas
Posts: 154
Joined: Thu Jan 12, 2012 1:53 pm
operating_system: Linux
System_Drive: X
32bit or 64bit: 64 Bit
motherboard: Asus in Workstation and Dell XPS Notebook
processor: i7-980 and i7-2720QM
ram: 12GB - 8GB
Video Card: ATI FireGL
sound_card: on board
Hard_Drive_Capacity: 4.5TB Rd10
Monitor/Display Make & Model: Samsung Syncmaster 2343sw
Location: DE - Wermelskirchen
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by andreas »

looks like these may be the problems:

Code: Select all

27.23: "BError: type = 1013, "decompressRawData cancelled" in file ../src/NefReader.cpp:2251"
...
57.442: Error - Unable to load setting created with a later version of Bibble.
Can you start on a folder with fresh NEFS without xmp files?

Andreas
Linux - not Windows
Kneops
Posts: 212
Joined: Fri May 09, 2014 2:43 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: ASUS P8 Z68
processor: Intel i7 2600
ram: 16GB
Video Card: nVidia 450
sound_card: onboard
Hard_Drive_Capacity: 14 TB
Monitor/Display Make & Model: Dell U2713H & Spider4
Corel programs: ASP3
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by Kneops »

You mean when using the folder tab, not the catalog tab I assume.
I just did, but that doesn't give me the catalogs. But perhaps I don't quite understand what you mean.
Kneops
Posts: 212
Joined: Fri May 09, 2014 2:43 pm
operating_system: Linux
System_Drive: N/A
32bit or 64bit: 64 Bit
motherboard: ASUS P8 Z68
processor: Intel i7 2600
ram: 16GB
Video Card: nVidia 450
sound_card: onboard
Hard_Drive_Capacity: 14 TB
Monitor/Display Make & Model: Dell U2713H & Spider4
Corel programs: ASP3
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by Kneops »

I just tried something and now I have my catalogs back: I copied the rootdb file from the old folder to the new folder.
Nevertheless I think this can be considerd a bug. Updating to a new version should be basic and simple.
FalCT60
Posts: 153
Joined: Wed Feb 15, 2012 11:29 am
operating_system: Windows XP Pro
System_Drive: C
32bit or 64bit: 32 Bit

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by FalCT60 »

I'm facing the same issue : after installing the latest version, it asks for files and catalog location and, then
1- if I try to select the ones of the previous installation, it crashes
2- if I accept the ones that it suggests me, it works but
a- goodbye my settings
b- I have to re-enter my licence key.
Why can't ASP under Ubuntu correctly install simply retrieving the old parameters ?
Just one more thing : there are no NEFs nor XMPs on my disk.
EDIT :
OK, I found the reason : the version installed was rather old - 2.0.2.10 - and, at this time, it was AfterShotPro2, but since 2.1.2.10 it has become Aftershot2 !
Then, the versions are installed in folders called resp. AfterShotPro2 and AfterShot2, and they can be run independantly (but not together).
NB : 2.2.0.29 still refuses to run unless I remove the plugins (reading the release notes pointed me to this).
Hope they updtae the plugins so I can use ASP soon.

Regards,

J.-Luc
macr237
Posts: 38
Joined: Sat May 26, 2012 2:43 am
operating_system: Linux
System_Drive: C
32bit or 64bit: 64 Bit
ram: 4GB
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by macr237 »

Anyone know if this has been fixed yet?
I really want to install the update, but have been holding off.
Macr

:arrow: Visit my Flickr page.
macr237
Posts: 38
Joined: Sat May 26, 2012 2:43 am
operating_system: Linux
System_Drive: C
32bit or 64bit: 64 Bit
ram: 4GB
Contact:

Re: Updating to 2.2 on Ubuntu but won't start with 'old' set

Post by macr237 »

Kneops wrote:I just tried something and now I have my catalogs back: I copied the rootdb file from the old folder to the new folder.
Nevertheless I think this can be considerd a bug. Updating to a new version should be basic and simple.
The only rootdb that came up on a search was in my home folder. Is this the rootdb that you are referring to?
Macr

:arrow: Visit my Flickr page.
Post Reply