Jumpy videos

Moderator: Ken Berry

Post Reply
lostri
Posts: 4
Joined: Mon Mar 29, 2021 11:07 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit

Jumpy videos

Post by lostri »

Hi all,

By means of intro I am a light user of VS X7 - using it mostly out of passion to edit my holiday movies.

What I've noticed is that some of the video clips (.mts format) become jumpy / jerky after rendering them as part of a big project (e.g. a video clip is less than a minute long, while the overall project duration is around 1hr).
However if I only render the respective video clips (so overall project is 2-3 minutes), they play just fine after rendering.
The raw clips themselves, if played in VLC without any editing, are just fine, so that rules out any issues with the camera writing onto the SD card.

I was able to reproduce the problem on VS 2021. My machine is a Dell laptop with 16 GB RAM and 8 CPU cores.
Any help would be much appreciated.

Thanks
tletter
Posts: 923
Joined: Thu Jul 16, 2015 12:23 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
processor: i7-3632QM 2.2 GHz
ram: 16GB
Hard_Drive_Capacity: 1TB
Corel programs: X4, X5, X6, X7, X8, X9, X10, 2018, 2019
Location: Canada

Re: Jumpy videos

Post by tletter »

lostri wrote:I've noticed is that some of the video clips (.mts format) become jumpy / jerky after rendering them as part of a big project
Your profile doesn't list which version of VS you're using and you mention both X7 and VS2021.

Some things to investigate:
  1. Which filter are you applying to the jumpy clips?
  2. Do the properties of the rendered videos match those of the jumpy clips? Generally, VS can match those properties.
Suggest that you allow VS to match the properties of the jumpy clips, disable all filter on the jumpy clips, and then re-render. How do the jumpy clips look then?

tletter
https://www.youtube.com/user/tletter
lostri
Posts: 4
Joined: Mon Mar 29, 2021 11:07 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit

Re: Jumpy videos

Post by lostri »

Hi tletter,

Thanks for your reply - to clarify, I first noticed the problem on VS X7. In the meantime i've upgraded to 2021, but the issue still persists.

I've done some more tests rendering only few sample clips in various output formats - the output is smooth.
However if i render them as part of a longer project, they come out very jumpy.

Using no effects, only adjusted the volume and added some bground music.

I suspect it's got smth to do with the project settings for the longer project, but can't figure out what.

Thanks for your help
tletter
Posts: 923
Joined: Thu Jul 16, 2015 12:23 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
processor: i7-3632QM 2.2 GHz
ram: 16GB
Hard_Drive_Capacity: 1TB
Corel programs: X4, X5, X6, X7, X8, X9, X10, 2018, 2019
Location: Canada

Re: Jumpy videos

Post by tletter »

lostri wrote:I suspect it's got smth to do with the project settings for the longer project, but can't figure out what.
Why and how do the properties of your longer VSP differ from your shorter one, if they're both using the same type of source files?

As previously asked:
  1. What are the properties of your source clips?
  2. What are the properties of your VSP?
  3. Do they match? If not why not?
tletter
https://www.youtube.com/user/tletter
User avatar
lata
Site Admin
Posts: 12727
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: Jumpy videos

Post by lata »

Jumpy playback could indicate that you need to use Smart Proxy files, these are additional files created for each clip that does improve timeline playback improving the editing experience.

Go to Settings – Smart Proxy – Enable or Preferences (F6) – Performance tab for further options.
Smart Proxy files will/should be created when adding/inserting clips to the timeline.
For clips already being used, right click the clip and choose Create Smart Proxy Files. (Shift + Click will select more clips)

The process does take a while to complete, View Settings Smart Proxy Queue Manager to view progress.
Proxy files can also be created from the library clips.

Once complete a small icon will show on the clip.
click image for larger view
click image for larger view
Regards Trevor
lostri
Posts: 4
Joined: Mon Mar 29, 2021 11:07 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit

Re: Jumpy videos

Post by lostri »

Thanks both for your replies.

After fiddling with different settings I figured that if I change project settings to Mobile and then render as MPG-4, the problem is gone!

It turns out my project settings defaulted to DVD, however when rendering I would always select MPEG-4. This combination produces videos that are jumpy at times (only specific clips) and only when part of a longer project.
If I render just one of the clips, the output is just fine.

Still intrigued by this behaviour, but certainly glad I found this workaround. Hopefully it helps other newbies such as myself in the future.
User avatar
lata
Site Admin
Posts: 12727
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: Jumpy videos

Post by lata »

If as you say the videos are MTS then the project properties should have reverted to Motion Transport Stream and not DVD
Show Messages being set in preferences should take care of that.

Typically
MPEG Transport-Stream Files
24 bits, 1920 x 1080, 50 fps
Frame-based
(HDMV-PAL), 16:9
H.264 Video
Video data rate: Variable (Max. 26000 kbps)
Audio data rate: 384 kbps
Dolby Digital Audio, 48 KHz, 2/0(L,R)


Right click a MTS clip and choose properties, what are they? “tletter” asks for these details in his post. “3. Do they match? If not why not?”

You should take note of the frame rate and type, when converting to Mpeg4 make sure the frame rate and frame size are the same.

as a test, start a new project, make sure Show Messages is selected via Preferences (F6)
Insert one of your MTS clips to the timeline should show a message
Choose Details to view the settings, the righthand panel shows the video files properties (copy and paste details to your post)
Choose Yes to set properties
Regards Trevor
lostri
Posts: 4
Joined: Mon Mar 29, 2021 11:07 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit

Re: Jumpy videos

Post by lostri »

Hi lata,

These are the properties of one of the clips that becomes jumpy after rendering.
Is there a particular project format you could advise based on this? MTS does not seem to be an option, at least not under this name.

File name: 00071.MTS
File format: PAL HDMV
Video Type: H.264 Video, Upper Field First
Attributes: 24 bits, 1920x1080, 16:9
Frame rate: 25.000 frames/sec
Data rate: Variable bit rate

Thanks
User avatar
lata
Site Admin
Posts: 12727
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: Jumpy videos

Post by lata »

If you view Settings - Project properties you should see ACVHD, the actual properties showing in the panel.

From Share – the default should be AVC/H.264
Top left is the option for Same as Project Settings, you need to tick the box to make active, there is also the option for Same as First clip
Note the Settings, again in the properties box.

Using the Same As options will create / render the project to the same settings as your video file.

What are the properties of the rendered video file are they the same?

click image for larger view
click image for larger view
Also set Smart Proxy for the new video file, as my reply here
https://forum.corel.com/viewtopic.php?p=386846#p386846

How does that video file play using your media players, VLC
Regards Trevor
Post Reply