High Quality mp4 s are muddy in VS2020 -SOLVED-

cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

High Quality mp4 s are muddy in VS2020 -SOLVED-

Post by cybernick »

has anybody faces such an issue?
Some of MP4 files (captures with OBS or Geforce experience) which are 1080p or 1440p and can be view extremely crisp in windows default player are muddy in VS2020. Not only in preview screen but also in render with the same specs of the initial file.
Last edited by cybernick on Tue Jan 19, 2021 12:02 pm, edited 1 time in total.
cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

Re: High Quality mp4 s are muddy in VS2020

Post by cybernick »

Anyone please?
Can it be something with codec. Should I install a codec?

I consider to make a clean reinstall. Will it be enough to install sp4 file?
Also mine is update version should I need to install VS19 first?
cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

Re: High Quality mp4 s are muddy in VS2020

Post by cybernick »

I did a repair installation. No solution.
To explain what I mean I have attached a zip file with two files.
The orijinal high res MP4 file and the rendered file with exactly the same specs in VS2020. You can see what VS2020 did to the file.
What do I miss. Please suggest.

https://drive.google.com/file/d/1Va6_Nq ... sp=sharing
asik1
Posts: 3106
Joined: Thu Apr 17, 2014 6:07 am
operating_system: Windows 7 Professional
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: H170M-E D3
processor: i5-6600
ram: 8gb
Video Card: GTX1050
Hard_Drive_Capacity: No hoarder
Monitor/Display Make & Model: Philips 19" + samsung 19"
Corel programs: VS-X9.2
Location: Israel

Re: High Quality mp4 s are muddy in VS2020

Post by asik1 »

Indeed it's crap as I always said. VS's mp4 is not good for animation. This is why I use only WMV when I have animation segment.
cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

Re: High Quality mp4 s are muddy in VS2020

Post by cybernick »

Was is always like this? Because it was way better in early versions.
Or I did something and works like this?
User avatar
lata
Site Admin
Posts: 12605
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: High Quality mp4 s are muddy in VS2020

Post by lata »

Hi Nick
I was a little concerned in comparing the original properties, I used Media Info
The video is using a variable frame rate which Video Studio does not get on well with, sometimes that is
There was also a reference to Pal which in its self not a problem but then the frame rate of 60 would indicate NTSC, so I was a little confused and did not understand if that would be an issue

With Pal / Ntsc in mind I set my 2020 to NTSC, F6 – Preferences – TV System - rebooted the program

Also From F6 – Preferences – Edit Resampling Quality to Best

Imported the original to the timelines which prompted for a match of the Project Properties as :-
MPEG-4 Files
24 bits, 2560 x 1440, 60 fps
Frame-based
H.264 High Profile Video: 15606 Kbps
48000 Hz, 16 Bit, Stereo
MPEG AAC Audio: 96 Kbps

Share – Same as First Clip to create a new video file which looks ok, lets say I can read the writing on the map
Better to use VLC Media Player, or any player other than VS

Post Updated to add sample video
I have not used Google Drive for a while, hopefully this link works
https://drive.google.com/file/d/1m6251E ... sp=sharing

I also changed/deselected the F6 Preferences – Edit – Apply Colour Filter, did not seem to change anything although a subtle change is difficult to compare.
At the moment the colour filter is set to NTSC, even though I am in Pal UK
Regards Trevor
cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

Re: High Quality mp4 s are muddy in VS2020

Post by cybernick »

Can you please upload the file . I will also try the same.
User avatar
lata
Site Admin
Posts: 12605
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: High Quality mp4 s are muddy in VS2020

Post by lata »

Hi Nick
Just updated the post, did not realise it would display there, had thought a download link?
Regards Trevor
cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

Re: High Quality mp4 s are muddy in VS2020

Post by cybernick »

Ok I tested as you mentioned. No big change. Still VS2020 kills the quality of the media. Check this out

https://drive.google.com/file/d/1iOb-Ez ... sp=sharing
User avatar
lata
Site Admin
Posts: 12605
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: High Quality mp4 s are muddy in VS2020

Post by lata »

As you say no change there,
Did you manage to download the Lata Cybernic.mp4 sample on my google drive.


https://drive.google.com/file/d/1m6251E ... sp=sharing
Regards Trevor
cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

Re: High Quality mp4 s are muddy in VS2020

Post by cybernick »

lata wrote:
Mon Jan 18, 2021 1:44 pm
As you say no change there,
Did you manage to download the Lata Cybernic.mp4 sample on my google drive.


https://drive.google.com/file/d/1m6251E ... sp=sharing
OMG your render is way better. How you manage to do that. Mine is still garbage.
As first video or as the project the output is the same buddy video.
Do you have any codec pack installed. Can it be something related to that?
User avatar
lata
Site Admin
Posts: 12605
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: High Quality mp4 s are muddy in VS2020

Post by lata »

Just tried using Share – Same as Project Settings, this took much longer to render as though Smart Render is not being used, I think that may be the case.
Same good results, difficult to say if Same as First Clip with Smart Render is better quality or not?

Step by step
First is your program installed as Pal or Ntsc, I assumed Pal?

1 / Settings Preferences F6 – Set TV System to NTSC
2 / Edit Tab – Set Resampling Quality to Best
3 / Performance – Smart Proxy is deselected,
OK to close the panel
4 / Reboot the program.
5 / Add the original video allowing the Show Messages to change/match the Project Properties
6 / Share – top left for Same as project properties, I changed that to Same as first Clip.

I will revert my program back to Pal to see if I can render the poor quality again
Regards Trevor
User avatar
lata
Site Admin
Posts: 12605
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: High Quality mp4 s are muddy in VS2020

Post by lata »

Ok I have been through all my settings changing those one at a time and still unable to render a bad video
I have also checked Smart Proxy files as that has caused some quality issues

Maybe I need to reboot the computer to clear any cache files, strange that I can no longer render a bad one?
Regards Trevor
cybernick
Posts: 127
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Video Card: GTX 1060
Hard_Drive_Capacity: 1TB nvme
Corel programs: Video Studio 2020

Re: High Quality mp4 s are muddy in VS2020

Post by cybernick »

lata wrote:
Mon Jan 18, 2021 2:01 pm
Just tried using Share – Same as Project Settings, this took much longer to render as though Smart Render is not being used, I think that may be the case.
Same good results, difficult to say if Same as First Clip with Smart Render is better quality or not?

Step by step
First is your program installed as Pal or Ntsc, I assumed Pal?

1 / Settings Preferences F6 – Set TV System to NTSC
2 / Edit Tab – Set Resampling Quality to Best
3 / Performance – Smart Proxy is deselected,
OK to close the panel
4 / Reboot the program.
5 / Add the original video allowing the Show Messages to change/match the Project Properties
6 / Share – top left for Same as project properties, I changed that to Same as first Clip.

I will revert my program back to Pal to see if I can render the poor quality again
Iata,

I did exactly as you mention. First of all My Apply color fileter (pal/ntsc) was deselected. I choose NTSC anyway. And I exported as "same as first clip". No chnage. Terribly bad output.

I managed to get somehow usable output with mp4 custom share setting. With the following settings. Do you also use Ulead Mpeg-4 vio Driver?
As you can see I need to boost the bit rate to 65000 which caused the file size to become 300 MB.
Attachments
mp4.jpg
User avatar
lata
Site Admin
Posts: 12605
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: High Quality mp4 s are muddy in VS2020

Post by lata »

Yes the Ulead Mpeg-4 vio Driver? is available when setting the properties

When I first rendered the original video this morning the resultant video was as bad as your sample
I then tweaked my program settings to use NTSC thinking there may be a Pal / ntsc conflict
Then all renders were very good
I have since reset my program to my original Pal settings and still render good video
I have also booted up 2019 that should use the same setting as 2020, rendering using 2019 was good quality

so the first render was very poor, now I am completely confused as i can no longer replicate the poor video.
Regards Trevor
Post Reply