Page 1 of 1

Lagging badly during playback

Posted: Sun Jan 10, 2021 3:23 am
by ozzlvlosis
it seems like once i start building up my project with overlays and fx it lags to the point where i cant even work. It just skips and jumps and cant even watch the clip. If i render it its fine but i'm not rendering every time i want to see how a clip looks.
I didnt think i would be having these issues with the laptop i got. i have an i9 processor, 64gb of ram and an NVIDIA rtx 2070 videocard. Has anyone had these issues?

Re: Lagging badly during playback

Posted: Sun Jan 10, 2021 5:23 am
by tletter
ozzlvlosis wrote:It just skips and jumps and cant even watch the clip.
Have you enabled Smart Proxy and has a Smart Proxy file been created for all video clips?

tletter
https://www.youtube.com/user/tletter

Re: Lagging badly during playback

Posted: Sun Jan 10, 2021 5:34 am
by ozzlvlosis
No i'm not sure what that is but i'll try it

Re: Lagging badly during playback

Posted: Sun Jan 10, 2021 5:41 am
by ozzlvlosis
tried that. still getting the same lag

Re: Lagging badly during playback

Posted: Sun Jan 10, 2021 9:43 am
by Ken Berry
You said you'd try it at 4:34 pm (my time) and reported 8 minutes later you were still getting the lag. Creating SmartProxy files is not instantaneous. It takes time and patience. So depending on how long the clip was you were creating a SmartProxy for, you may not have allowed it sufficient time for creation.

Re: Lagging badly during playback

Posted: Sun Jan 10, 2021 11:36 am
by lata
Smart Proxy files are created automatically when inserting video to the timelines
However for clips already on the timeline we have to manually create these files
First go to F6 – Preferences – Performance tab – enable smart proxy
Now back on the timeline right click a clip, Shift + Click to select multiple clips, right click selection for Create Smart Proxy
As mentioned can take a while to create these files, this should improve the timeline playback.

A small double icon will show on the clip once proxy files have been created
click image for larger view
click image for larger view

Re: Lagging badly during playback

Posted: Sun Jan 10, 2021 10:58 pm
by ozzlvlosis
ok didnt know about that extra step regarding individual clips. i will try that now

Re: Lagging badly during playback

Posted: Sun Jan 10, 2021 11:23 pm
by ozzlvlosis
wow. i think this fixed it. thank you so much! so reading about smart proxy it creates a lower resolution file to make it easier on the processor. Does this need to be disabled for rendering or is it automatic?

Re: Lagging badly during playback

Posted: Mon Jan 11, 2021 2:03 am
by tletter
ozzlvlosis wrote:Does this need to be disabled for rendering or is it automatic?
The Corel VideoStudio 2019 User Guide can help you answer that question.
erase.jpg
tletter
https://www.youtube.com/user/tletter

Re: Lagging badly during playback

Posted: Mon Jan 11, 2021 10:18 am
by asik1
The fact that
"I didnt think i would be having these issues with the laptop i got. i have an i9 processor, 64gb of ram and an NVIDIA rtx 2070 videocard."
probably SSD also and still needs smart proxies is not good point for a software.

Re: Lagging badly during playback

Posted: Tue Jan 12, 2021 12:53 am
by Pepi
asik1 wrote:
Mon Jan 11, 2021 10:18 am
The fact that
"I didnt think i would be having these issues with the laptop i got. i have an i9 processor, 64gb of ram and an NVIDIA rtx 2070 videocard."
probably SSD also and still needs smart proxies is not good point for a software.
Actually, I have been too shy to ask, but do people really need that? I'm not using smart proxy even my clips are on HDDs. And have not seen any troubles. Perhaps I do too light work :?

Re: Lagging badly during playback

Posted: Tue Jan 12, 2021 3:52 am
by tletter
Pepi wrote:Actually, I have been too shy to ask, but do people really need that?
Not everyone is editing the same type of VSP on the same H/W. So yes some people do need Smart Proxy but clearly your happy editing w/o Smart Proxy. Are you editing 4K video w/o Smart Proxy?

P.S. Your profile doesn't indicate either the CPU or GPU that your using.

tletter
https://www.youtube.com/user/tletter

Re: Lagging badly during playback

Posted: Tue Jan 12, 2021 10:49 am
by lata
Video Studio does struggle a little working with MTS HD files, copes better with Progressive than Interlaced even with the high frame rates 50i to 50p
Import a lot of MTS files to the library, (100 or so) use the Import Media option then compare with drag and drop via windows explorer.
Working with Mpeg4 seems much easier for Video Studio, I have converted my MTS to Mpeg4 to see a better response in importing files.
Zoom in and out of the timelines and MTS are slow to refresh compared to other formats.

It is the way Video Studio handles MTS far to complex for me to understand and too much work for Corel to address.

Use Pinnacle Studio and MTS files are loaded / imported very fast, the program simply flies when working with MTS.