Smart Rendering fails

Moderator: Ken Berry

Post Reply
BikerDave1
Posts: 16
Joined: Tue Oct 03, 2017 7:00 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASRock x399 Taichi
processor: AMD TR 1950X
ram: 32GB
Video Card: Nvidia 1080ti
Hard_Drive_Capacity: 5726GB
Monitor/Display Make & Model: Samsung KU6300 55" 4K UHD TV
Corel programs: VS 10.5/2020 Ult, PS Pro 2018 Ult

Smart Rendering fails

Post by BikerDave1 »

My longest clip of 1hr 2min fails during/after rendering while Smart Rendering enabled. I only put a Transition before/after the clip. Using Cuda or Intel encoding makes no difference. Two things happened:

1. The Status popup during rendering showed the Percentage value vs the Completion Bar differ greatly. As an example, if it shows 50% complete but the bar only shows about 25% complete. After it gets to 100% the bar shows about 75% complete.

2) Watching the final output file: starts off correctly with the transition. The video chugs along properly with the video/audio in synch until about 90% of the video. Then the video freezes from that point on to the end while the audio plays correctly from beginning to the end.

I searched the VideoStudio Forum for similar issues but nothing came up at all.

The immediate solution was to disable Smart Rendering and re-render after removing/recreating the TimeLine. The result, though slow rendering, was correct from beginning to end with the transitions before and after. I have the latest VS 2020 Ultimate.

Thoughts?
User avatar
lata
Site Admin
Posts: 12688
Joined: Thu Jan 19, 2012 6:21 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X 0x
processor: 4 10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVSX10, 18, 19, 20, PSP, PI, MS3D
Location: UK
Contact:

Re: Smart Rendering fails

Post by lata »

Hi BikerDave1
I would suspect the type of video file used, if it uses variable frame rates then video studio may struggle and we would recommend deselecting Smart Render.
Smart Render will only work efficiently where our project properties match the video files properties.

Can you give details of the video file, right click the clip and choose properties, what are they? you could create an image of the panel to attach to your post.
Can you also show the Settings - Project Properties, (Alt+Enter)
Regards Trevor
BikerDave1
Posts: 16
Joined: Tue Oct 03, 2017 7:00 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASRock x399 Taichi
processor: AMD TR 1950X
ram: 32GB
Video Card: Nvidia 1080ti
Hard_Drive_Capacity: 5726GB
Monitor/Display Make & Model: Samsung KU6300 55" 4K UHD TV
Corel programs: VS 10.5/2020 Ult, PS Pro 2018 Ult

Re: Smart Rendering fails

Post by BikerDave1 »

Hi Trevor,
Thanks for the reply. Today I had time and spent a few hours going through the problem. After trial and error trying all sorts of things (and just about ready to throw in the towel), I determined that the file was in some way corrupt! I determined that by Smart Rendering a slightly shorter different file which worked just fine. I re-encoded the original problematic file with HandBrake and then retried again with and without the Transitions. Both worked correctly! The original 1hr2min MP4 file rendered with Transitions (exactly as defined in the original post) in just a bit over 3 minutes!! It was a strange one as the original file looked just fine in the Properties as well as on the timeline & playback in VideoStudio. Just glad it wasn't the computer nor the program. So all is well thank goodness!
Post Reply