Audio glitches in mp4 and mov files

Audio glitches in mp4 and mov files

Postby cybernick » Tue Jul 07, 2020 10:31 pm

During the preview and also after render I face some audio glitches (some random noises in millisecond level) when I used audio from mp4 and mov files. No issue in wmv and wav files.
As long as I use vmw and wav files for audio the outputs in mp4 and mov are ok to be played in other software. But when I use these outputs again in Video Studio I have the same issues. Obviously VS can not handle some audio codecs.
I have the same issue in both VS 19 and VS 20.

Any ideas or any who had the same issue?
cybernick
 
Posts: 20
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Hard_Drive_Capacity: Istanbul
Corel programs: Video Studio x9

Re: Audio glitches in mp4 and mov files

Postby tletter » Tue Jul 07, 2020 10:51 pm

cybernick wrote:I have the same issue in both VS 19 and VS 20.

Do you mean X9 and X10 or VS2019 and VS2020?

cybernick wrote:I face some audio glitches (some random noises in millisecond level)

In the following image, you can see that the audio clip is supposed to fade out but VS introduces an audio blip that has to be removed in a sound editor, e.g. Audacity, and then the project rendered again with the new audio track. Obviously this extra step is a waste of time, but unfortunately Corel isn't interested in fixing such a basic flaw.
erase.png

cybernick wrote:Any ideas or any who had the same issue?

If you search this forum for "blips", you'll find that VS has been adding audio blips to rendered files since at least X9, e.g. see https://forum.corel.com/search.php?st=0 ... only&ch=-1.

tletter
https://www.youtube.com/user/tletter
tletter
 
Posts: 715
Joined: Thu Jul 16, 2015 12:23 am
Location: Canada
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
processor: i7-3632QM 2.2 GHz
ram: 16GB
Hard_Drive_Capacity: 1TB
Corel programs: X4, X5, X6, X7, X8, X9, X10, 2018, 2019

Re: Audio glitches in mp4 and mov files

Postby cybernick » Tue Jul 07, 2020 11:24 pm

I mean VS 2019 and VS 2020.

It is not in fade out or fade in. It is hard to notice but very annoying. Very small glitches randomly in the video
cybernick
 
Posts: 20
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Hard_Drive_Capacity: Istanbul
Corel programs: Video Studio x9

Re: Audio glitches in mp4 and mov files

Postby tletter » Wed Jul 08, 2020 12:03 am

cybernick wrote:Very small glitches randomly in the video

A "very small glitch" is shown in the image - look at the timescale. However, in order to clarify what you mean, you should capture and post an image showing your blip/glitch.

tletter
https://www.youtube.com/user/tletter
tletter
 
Posts: 715
Joined: Thu Jul 16, 2015 12:23 am
Location: Canada
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
processor: i7-3632QM 2.2 GHz
ram: 16GB
Hard_Drive_Capacity: 1TB
Corel programs: X4, X5, X6, X7, X8, X9, X10, 2018, 2019

Re: Audio glitches in mp4 and mov files

Postby cybernick » Mon Jul 13, 2020 1:27 pm

Glitch I am talking is even smaller and it is random.
For example I send a file.
https://we.tl/t-EQTajvLWO0
By the end of the first second you will hear a small "cheet" sound. I have it randomly with MP4 files.
To avoid this I have starting using wmv files. But it is convenient. Any ideas.
cybernick
 
Posts: 20
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Hard_Drive_Capacity: Istanbul
Corel programs: Video Studio x9

Re: Audio glitches in mp4 and mov files

Postby tletter » Tue Jul 14, 2020 3:21 am

cybernick wrote:To avoid this I have starting using wmv files. But it is convenient. Any ideas.

erase.jpg

Clicks/pops such as the one that you experienced (see image) occasionally occur in rendered videos. In my experience, these clicks/pops aren't strictly restricted to MP4 and they happen in other formats, e.g. m2t and wav. However, they can be removed using Audacity, although this removal shouldn't be required. In short, VS has sporadic audio bugs when rendering.

tletter
https://www.youtube.com/user/tletter
tletter
 
Posts: 715
Joined: Thu Jul 16, 2015 12:23 am
Location: Canada
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
processor: i7-3632QM 2.2 GHz
ram: 16GB
Hard_Drive_Capacity: 1TB
Corel programs: X4, X5, X6, X7, X8, X9, X10, 2018, 2019

Re: Audio glitches in mp4 and mov files

Postby cybernick » Fri Jul 17, 2020 7:49 am

If I convert the audio part to wav 24 bit I face very few of those clicks.
I have contacted Corel support the suggest to reset library and delete windows temp (standart answer).
I really do not know how to handle the issue. I love the tool and I feel confortable working with it but those type issues and some abnormal shutdowns make me seek.
cybernick
 
Posts: 20
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Hard_Drive_Capacity: Istanbul
Corel programs: Video Studio x9

Re: Audio glitches in mp4 and mov files

Postby lata » Sat Jul 18, 2020 10:13 am

Hi
Could this be associated with the Hz setting, I notice the sample is using 41000Hz and there does appear to be a difference using Video Studio
The Project Properties settings for Mpeg4 - OnLine use 44100 Hz, 16 Bit, Stereo whereas the Mobile options use 48000 Hz, 16 Bit, Stereo, I have not viewed every profile.
Choosing profiles from Share Mpeg4 appear to use both depending on which I choose
So would changing the Hz rate when rendering cause a reduction in quality.

cybernick
The sample is clearly a copy of the original, what are the properties of the original 48000 or 44100 Hz?
What are the properties of the original video files,
What are the Project Properties
And what do you choose from Share, or the properties of the final output file?

I have tried to replicate this sound issue using various HZ settings but so far I don’t have a problem so the above may be just clutching at straws, even so may be worth considering.
Regards Trevor
User avatar
lata
Site Admin
 
Posts: 11942
Joined: Thu Jan 19, 2012 6:21 am
Location: UK
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: ASUSTeK COMPUTER INC A88XM-A USB 3 1 Rev X.0x
processor: 4.10 gigahertz AMD A10-7890K Radeon R7
ram: 16 gb
Video Card: on board
sound_card: Realtek High Definition Audio
Hard_Drive_Capacity: 500 SSD
Monitor/Display Make & Model: LG W2242 [Monitor]
Corel programs: CVS7, 9, 10, 18, 19, 20, PSP, PI, MS3D

Re: Audio glitches in mp4 and mov files

Postby cybernick » Tue Jul 21, 2020 10:32 am

The source file I use has AAC audio in 32kHZ and 54kbps. I change the project properties to 32kHZ and 64kbps (no 54 kbps option) but glitch is still there. The only workaround I found is to get out the audio from the video. Convert it in wav in goldwave and then add it in a WMV format in the video. And use that wmv as source. But it is very time and space consuming operation. :(
cybernick
 
Posts: 20
Joined: Mon Jan 21, 2019 7:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
Hard_Drive_Capacity: Istanbul
Corel programs: Video Studio x9


Return to VideoStudio

Who is online

Users browsing this forum: No registered users and 28 guests