Page 1 of 1

video and photo missing from a saved VSP file

Posted: Thu Jun 11, 2020 7:41 pm
by forestraven
Hello all,
I am using VS X8 on a Win8.1 computer.
I was working on a project last year. I am creating a video for my daughter of her cat who passed away using short video clips and photos.
I was doing each year individually. I had saved all of 2006 and 2007. They were complete with all the photos, videos, special effects, etc. I saved them as the VSP files.
I then had no opportunity to work on them until last week. When I opened the files I found the transitions were still in place along with texts I had added but all the photos and video clips were missing from both files. There were only blank white spaces of various lengths between the transitions where the photos and video clips should have been.
How can clips go missing from a saved vsp file?
I tried re-inserting the clips but now they don't seem to fit in the spaces.
I've attached a screen shot so you can see what I am seeing.
This is really frustrating because it took a number of hours to get as far as I did. I don't want to have to start all over.
Files may have been moved around on my computer since then but still, once a vsp file is saved shouldn't everything be saved without the need to refer back to original locations??
Would really appreciate some help figuring this one out.
Thank you.

Re: video and photo missing from a saved VSP file

Posted: Thu Jun 11, 2020 7:53 pm
by Ken Berry
forestraven wrote:Files may have been moved around on my computer since then but still, once a vsp file is saved shouldn't everything be saved without the need to refer back to original locations??
Unfortunately, the answer is "No"... A VSP file is only a small text file, telling Video Studio what is in a project -- clips, filters, transitions, audio etc -- where it is stored and what has been done to it. It does NOT save any material (video, photos, audio). So if your material was on, say, an external hard drive and you reopened the project without that hard drive connected, or connected with a different drive letter, then Video Studio would not be able to insert the necessary videos or photos. Or if it was on you computer but was moved to another folder, or worse, deleted because you thought you had saved it, then it would no longer be available in the project. However, in your case you clearly have that material still available.

Normally, though, VS would ask if you want to relink the videos and photos. Did you get such a message?

Re: video and photo missing from a saved VSP file

Posted: Thu Jun 11, 2020 7:55 pm
by tletter
forestraven wrote:Files may have been moved around on my computer since then but still, once a vsp file is saved shouldn't everything be saved without the need to refer back to original locations??
No, as a VSP just contains pointers to the location of the images when you last saved it. Hence if you moved the images around your file system then you've broken the pointers and must relink the pointers to the new locations. You'll need to find the images on your file system and use the relink feature to tell VS where they are now located. The 'Smart search' option of Relink may be helpful.
forestraven wrote:How can clips go missing from a saved vsp file?
Because a VSP doesn't contain any images/videos. If you want to save all images/videos in a package then use the Smart Package feature.

tletter
https://www.youtube.com/user/tletter

Re: video and photo missing from a saved VSP file

Posted: Sun Jun 14, 2020 10:23 pm
by forestraven
Thank you. Apparently I misunderstood the nature of a VSP file.
In the past, the program did ask me to relink but it isn't doing it now. Nor can I find a way to get it to do that. That would be the simplest way to restore things but for some reason, it is not coming up.
Is there a way I can manually force it to relink?

Re: video and photo missing from a saved VSP file

Posted: Sun Jun 14, 2020 11:06 pm
by tletter
forestraven wrote:In the past, the program did ask me to relink but it isn't doing it now.
Firstly, if you've already relinked videos/images then a relink option is not offered. However, if you haven't relinked then as previously explained, ensure that the Preferences -> General -> Relink checking feature is enabled, and then re-open your VSP.

tletter
https://www.youtube.com/user/tletter

Re: video and photo missing from a saved VSP file

Posted: Mon Jun 15, 2020 9:12 am
by lata
Hi
Just to add that when you see the re-link window the last known file location is shown at the top of the panel, also shows on the next browse panel.
Make sure you select the correct file, the program will re-link to other / wrong files especially images, but It will also re-link to wrong video should the durations be appropriate.

And manually force a relink I believe will only do one clip at a time
Select a clip, from the menu – File - Relink

You can also drag a clip from the library to the timeline, hold CTRL for “replace clip” and drop over your clip.

Re: video and photo missing from a saved VSP file

Posted: Mon Jun 15, 2020 5:21 pm
by tletter
lata wrote:You can also drag a clip from the library to the timeline, hold CTRL for “replace clip” and drop over your clip.
It's important to know that replacing a clip is not always the same as relinking. Specifically if you've trimmed a video clip then replacing a clip will not give the same results as relinking, i.e. your editing effort will be lost.

tletter
https://www.youtube.com/user/tletter

Re: video and photo missing from a saved VSP file

Posted: Mon Jun 15, 2020 6:36 pm
by lata
Hi
Thanks for that, yes there is an issue where video clips have been trimmed
All other edits do seem to be retained, probably best to avoid using Replace Clip, although I would think Corel should be able to fix that?

Re: video and photo missing from a saved VSP file

Posted: Fri Jun 19, 2020 8:49 pm
by forestraven
Thank you to all of you for your help.
I did find that the relink option had been somehow unchecked. It's working now. All I have to figure out is which files go where. :)

Re: video and photo missing from a saved VSP file

Posted: Sat Jun 20, 2020 9:27 am
by lata
forestraven wrote:Thank you to all of you for your help.
I did find that the relink option had been somehow unchecked. It's working now. All I have to figure out is which files go where. :)
Hi
Relinking should not cause you any problems, by that I mean it should work ok, can be a bit of a pain to do.
When you see the first re-link window the original file location is showing at the top of the window

My image 1 shows E:\Circus\ followed by the file name C0012-Copy.MP.4

In your case I suspect the drive may have changed, for this test i have renamed the file
You should now use Windows Explorer to search for the actual files new location

Now selecting Re-link will open a browser (image 2) allowing you to navigate to the file in its new location.
A process, Smart Search Re-link will / should select all other files within that folder and re-link all.

I would suggest that you now save the project, then re-open to see if that activates the re-link, there may be other files in another location.
2020 relink1.jpg
click image for larger view
click image for larger view