NEW! PaintShop Pro 2019

Crop Tool - "Last Applied" does not work

Corel Paint Shop Pro

Moderator: Kathy_9

Crop Tool - "Last Applied" does not work

Postby Bareboats » Sun May 05, 2019 2:19 am

After editing a couple thousand photos and cropping them, the crop tool has gone gollywonkers. The "Last Applied" option no longer works and it is slowing me down ... A LOT!

When I select "Last Applied", it stays on Free Form. I then have to use the handle to select the size I need because when I try to put the pixel number in the dimensions box, it just immediately goes back to where it was. As I'm sure many of you know, the handle is not all that accurate and I end up having to fiddle with it until I get it back to where I need it. It's really frustrating.

Are there any fixes? I have tried resetting all tools but that didn't work either. I still have about a thousand more photos to edit. :|
Bareboats
 
Posts: 13
Joined: Fri Feb 08, 2019 10:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
processor: Intel Core i7-7700HQ CPU 2.80GH
ram: 64.0GB
Hard_Drive_Capacity: 3TB
Monitor/Display Make & Model: Lenovo Thinkpad P51
Corel programs: Corel Paintshop Pro 2019 Ultimate

Re: Crop Tool - "Last Applied" does not work

Postby ehume » Sun May 05, 2019 2:52 am

Try saving your workspace as a named workspace, THEN use File > Preferences > Reset Preferences. Then restore your named workspace. If you go this route, do not neglect to do all three steps.
Had PS3, PSP3; Installed: PSP-4.12, 5.03, 6.02, 7.04 (liked it a lot & used it for years), 9.00, 10, 11, x4, x6, x7, x8, x9; now using PSPx10 (PSP 2018; version 20.2.0.1 x64) on Win 10-64; rejected PSP 2019.
User avatar
ehume
 
Posts: 493
Joined: Tue Sep 18, 2012 2:05 am
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Gigabyte GA-Z87X-UD4H
processor: i7 4770k
ram: 16GB
Video Card: Intel HD4600
sound_card: no_sound_card
Hard_Drive_Capacity: 512GB+4TB
Monitor/Display Make & Model: Acer KN242HYL
Corel programs: PSP 2018 32b & 64b, AS3 64b, PE5 64b

Re: Crop Tool - "Last Applied" does not work

Postby hartpaul » Sun May 05, 2019 6:08 am

Also set up a preset corresponding with the dimensions you want and when it changes (I noticed it changing sometimes back in PSP X2) you just use that preset again (making sure you have Maintain Aspect Ratio clicked).
Systems available Win7, Win 8.1,Win 10 Version 1607 Build 14393.2007 & version 1809 Build 17763.615
hartpaul
Advisor
 
Posts: 2547
Joined: Tue Mar 20, 2012 3:38 pm
Location: Australia
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: AsusTex P7P55D
processor: IntelCore I 5 2.67 Ghz
ram: 8 Gb
Video Card: Nvidia GeForce GTX 460
sound_card: Nvidia High Definition Audio
Hard_Drive_Capacity: 1000 Gb
Monitor/Display Make & Model: AOC
Corel programs: PSP8,X2 to X9,2018,2019

Re: Crop Tool - "Last Applied" does not work

Postby Bareboats » Sun May 05, 2019 12:08 pm

Thanks so much to both of you. I've successfully managed to do both ... at least I "think" I was successful.

I'm not sure about the aspect ratio though. When I resized the photo, the aspect ratio was of course on ... but I didn't find a way to make sure it was still on when I set the preset size for the crop. I hope it is on. :(

You've saved me a lot of frustration with this fix.

One other thing that is taking time I don't have ... is that after adding type (my copyright) and then trying to locate the type where I want it to go ... it will "most of the time" stay on the vector ... but often changes to raster and I have to click on the vector again. Many times, I have to do this several times before it will stay on vector.

I found that if I go to the rectangle tool and click on vector and then back to the move tool, that somehow fixes the problem. Am I using the tool incorrectly? I suspect I am. :oops:
Bareboats
 
Posts: 13
Joined: Fri Feb 08, 2019 10:44 pm
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
processor: Intel Core i7-7700HQ CPU 2.80GH
ram: 64.0GB
Hard_Drive_Capacity: 3TB
Monitor/Display Make & Model: Lenovo Thinkpad P51
Corel programs: Corel Paintshop Pro 2019 Ultimate

Re: Crop Tool - "Last Applied" does not work

Postby MarkZ » Sun May 12, 2019 8:02 pm

Bareboats wrote:One other thing that is taking time I don't have ... is that after adding type (my copyright) and then trying to locate the type where I want it to go ... it will "most of the time" stay on the vector ... but often changes to raster and I have to click on the vector again. Many times, I have to do this several times before it will stay on vector.

I found that if I go to the rectangle tool and click on vector and then back to the move tool, that somehow fixes the problem. Am I using the tool incorrectly? I suspect I am. :oops:

I interpret your note to say that after applying text you want to move the text to a different spot on your image and when you try to do that you sometimes inadvertently click outside the vector area and make the underlying raster layer active. Yes, this is frustrating and I've done it many times.

Use the layers palette to help with selecting the text vector. In the attachment the layer with "Chris's cat" is blue indicating that it is the active layer and a box appears around the text. Use the pick tool (second tool in the tools palette, white arrow pointing up and to the left) rather than the move tool for moving the text. When the pick is hovering in the center of the text box the icon changes from a single arrow to four arrows in a cross; this indicates you can click on the text and drag it to where you want. If you miss, click on the vector layer again to select it and repeat the process. You should be able to accomplish your move fairly quickly using this process.


PSP2019-14.jpg
Text vector layer active
Mark
User avatar
MarkZ
 
Posts: 1076
Joined: Sat Feb 05, 2011 10:41 pm
Location: Toronto
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Intel DQ67SW desktop
processor: Intel Core i7 i7-2600 3.40 GHz
ram: 8 GB
Hard_Drive_Capacity: 500 GB
Monitor/Display Make & Model: LG Flatron E2241
Corel programs: PSP 2018 X9 X8 X7 X6 ASP3 ASP

Re: Crop Tool - "Last Applied" does not work

Postby JoeB » Mon May 13, 2019 1:36 am

Or, alternatively, if you have the Move tool active just hold down the Shift key then you can click and hold anywhere in the image and drag the vector layer. The Shift key with the Move tool will make the move tool lock onto whichever layer is active (highlighted in blue) in the layer's palette, even if that layer is hidden behind another layer.
Regards,

JoeB
Using PSP 2019 64bit
JoeB
 
Posts: 2369
Joined: Fri Mar 28, 2008 10:04 pm
Location: Canada
operating_system: Windows 8.1
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: LENOVO 4524PE4 ThinkCentre M91p
processor: 3.10 gigahertz Intel Quad Core i5-2400
ram: 8 GB
Hard_Drive_Capacity: 4.6 TB
Corel programs: PSP 9, X7 to 2019, 32 & 64-bit

Re: Crop Tool - "Last Applied" does not work

Postby MarkZ » Mon May 13, 2019 10:31 pm

JoeB, thanks, very useful tip.
Mark
User avatar
MarkZ
 
Posts: 1076
Joined: Sat Feb 05, 2011 10:41 pm
Location: Toronto
operating_system: Windows 10
System_Drive: C
32bit or 64bit: 64 Bit
motherboard: Intel DQ67SW desktop
processor: Intel Core i7 i7-2600 3.40 GHz
ram: 8 GB
Hard_Drive_Capacity: 500 GB
Monitor/Display Make & Model: LG Flatron E2241
Corel programs: PSP 2018 X9 X8 X7 X6 ASP3 ASP


Return to Paint Shop Pro

Who is online

Users browsing this forum: No registered users and 7 guests