NEW! Corel PaintShop Pro 2018

Checking in...

Checking in...

Postby asande » Tue Mar 27, 2012 2:41 pm

I still check out this forum from time to time - but was just wondering who's still using MSP? I actually bought Vegas Pro last year and did a couple of small projects on it, but found myself coming back to MSP8 for the bulk of my video work last year (5 of 6 video projects were done with MSP) as it just "felt" better, and while I found Vegas worked well, the comfort level just wasn't there (possibly just due to unfamiliarity, but for me, being able to integrate the Smartsound music tracks directly into the timeline is one of the major features that works well, as does the handling of timelapse sequences and compositing...

Even unsupported and past the end of its "life", MSP 8 still does the trick for me. I'm still running a dual core XP Pro based system for video editing, so realistically can't see changing for the foreseeable future, or until I'm "forced" into it, which isn't likely to happen soon as I am still working in the standard definition world for the most part.

By the way, my OS path is leading more into Linux and other alternatives and away from the Windows environment for my personal computing...

Anyone else having similar experiences?

Al
asande
 
Posts: 58
Joined: Fri Dec 10, 2004 1:49 pm
Location: Terrace, BC

Re: Checking in...

Postby Wim Kok » Wed Apr 04, 2012 9:13 pm

Hi Al,

“Even unsupported and past the end of its "life", MSP 8 still does the trick for me.............”

Fully agree. I had a new machine built in order to be able to continue with MSP8. This pc has a six-core processor and...............instead of a HDD C: is a SSD. OS is XP Pro and my editing format is HDV.
I can compare just like you since also Vegas is on this machine.
After my switch from SD to HD some years ago I discovered how far MSP8 already was in it’s development when it came out in 2005.
Yes indeed............... I still enjoy Ulead.
Regards, Wim Kok[newwindow=][/newwindow]
Wim Kok
 
Posts: 94
Joined: Mon Nov 19, 2007 5:59 pm
Location: The Netherlands
operating_system: Windows 7 Home Premium
System_Drive: C
32bit or 64bit: 64 Bit
processor: AMD FXtm-4100 Quad-Core
ram: 8 GB
Video Card: NVIDIA GT 520
sound_card: Realtek AC97
Hard_Drive_Capacity: C640 D500
Monitor/Display Make & Model: Acer AL1951 LCD


Return to MediaStudio Pro

Who is online

Users browsing this forum: No registered users and 2 guests