Page 1 of 1

Painting Creator bug introduced in VS2018

PostPosted: Fri May 18, 2018 3:32 am
by Davidk
I'm creating a project in VS2018 (version 21.2.0.113), and I want to draw an overlay on a picture image using the painting creator tool, something I have done many times before using prior versions. This is a screenshot of vsp before I started:
Thursday island pant creator_2018  1.jpg


The image I'm trying to "draw on" is the second satellite image of thursday island seen in the timeline of the vsp here. But when the image is selected and painting creator is opened (tools\painting creator at the bottom of the list), this is a screenshot of the tool window that opens:
Thursday island paint creator_2018 2.jpg


Never seen this before. Nothing I did (closed and opened the PT tool several times) changed the black content of the tool window, but I did manage to crash vs2018 several times trying.
Analysis
I saved the vsp from 2018 as an x10 file, and re-opened that vsp using x10 (version x10.5.0.60). Selected the image, and opened the PC tool: and voila - normal PC window as expected. I took this screenshot of the PC window in X10;
Thursday island paint creator_x10.jpg


Using X10, I created the 'drawn over' overlay I wanted, played it OK, and saved the vsp. Re-opened that vsp using Vs2018, and the the project file played correctly - the image and drawn overlay displayed OK.

So, it seems that a new bug exists in the painting creator tool window as executed in 2018. At least on my machine. Anyone else having this experience, and how do I report it to Corel?

Re: Painting Creator bug introduced in VS2018

PostPosted: Fri May 18, 2018 4:10 am
by RobertOZ
Sorry David, unable to replicate, Painting Creator seems to be working correctly on the laptop

Re: Painting Creator bug introduced in VS2018

PostPosted: Fri May 18, 2018 4:15 am
by gewb
Hi Dave -

Could not duplicate (it worked just fine).

Regards,
GEWB

Re: Painting Creator bug introduced in VS2018

PostPosted: Fri May 18, 2018 11:20 am
by Davidk
After Robert's and gwb's responses, I tried something new - a clean VS 2018 start, and only 2 jpg images loaded: one from my compact canon sx280 camera, and one from Google maps (the satellite image I was experiencing trouble with in the vsp). I thought that if there was any issue with the satellite image format, these would give a good comparison.

And for each image, selected it and chose painting creator. AND the PC tool window opened normally. puzzlement reins . . .

Next I opened 2018, and saved the original vsp as a test file, and having opened the test file began removing clips, photo's voice files and music, one-by-one and at each deletion, again trying to open Painting creator on the satellite photo image. The rationale was to find the item that changed the PC selection from a fail to good. But every test of PC was a fail. getting frustrated more than bit here . . .

Then I tried opening the original test file, and opened the PC tool on any image - all failed. Closed the test vsp and chose a new project (a clean timeline . . .), imported just the satellite image (this is similar to the test outlined in para 2 above) and opening PC on it failed. tearing hair stage, but there's not much left after age has removed most of it . .

Next test - opened a clean 2018, imported the satellite image and opened the PC tool on it - and the window opened OK. Selected open project and chose the original vsp. That opened Ok, but selecting the PC tool failed again when I tried to apply the PC tool to the satellite image. Closed that project (File/new project) and started a new project without shutting 2018 down. Imported the satellite image again (as for start of this para) and selected the PC tool on it - and it failed.

Conclusions.
1. Something in creating a 2018 vsp has damaged the program re opening the painting creator tool on a selected photo image, and deleting various elements from the affected vsp did not fix the 'PC tool failing' issue.
2. And once damaged, removing the original project file and opening a new one in the same session of VS has the same PC tool fail effect on that new project file.
3. Completely re-starting VS2018 seems to be the only way to remove what ever is causing the problem.
4. BUT it is VS2018 related - recall (original post) that I created an X10 vsp from the failing 2018 vsp (simply saved it as an X10 vsp format file), and after opening that x10 vsp under X10, the painting creator tool functioned normally on a selected image.

Asik has been commenting about these sort of issues for years and urging Corel to focus on fixing them. Seconded and thirded after this set of unstable performance from VS.

Re: Painting Creator bug introduced in VS2018

PostPosted: Fri May 18, 2018 3:13 pm
by plasmavideo
Just a thought . . . over time, I've discovered that sometimes oddball issues like this can be fixed by using a third party disc cleaning app, and selectively deleting temp files related to VSP, especially if the issue seems to be tied to one particular project. One I've used is Wise Disc Cleaner that's available on the Portable Apps platform (and probably as a standalone). It allows you to selectively delete temp files, and will identify those created by VSP and Paintshop Pro.

Re: Painting Creator bug introduced in VS2018

PostPosted: Sat Aug 04, 2018 2:22 am
by Davidk
PC uses win 7, and VS2018 is updated to sp3, version listed as 21.3.0.141, and this painting creator bug persists. Clearly, since others can't replicate it, it seems dependant on something, maybe several somethings, that's changed with the 2018 version - since the same X10 facility still works fine on the same PC platform.

Last time I just reverted to using X10, but that option, whilst working, really isn't viable now - I'm trying to demonstrate to a class this capability in version2018 and going back to the last prior version that works says a lot of bad things about the product to new users.

I even tried to create a paint on a map as the only things in the vsp, but that did not work either: these new images show that.
1st, the vsp up to the point of activating paint creator
using painting creator 1.jpg


and clicking the paint creator function gets this
using painting creator 2.jpg


I could create the paint mapping line using X10, and insert that mpg clip into 2018, but the scaling was all wrong on the background. Fiddling did not fix it either.

So, is there a way for a user to report these sorts of 'out of warranty' bugs to Corel?

Re: Painting Creator bug introduced in VS2018

PostPosted: Thu Aug 16, 2018 8:31 am
by Davidk
After extensive to-and-fro directly with lata on this, just as I was getting set up to capture the failure in detail, Paint creator in 2018 suddenly started working. And for a while, it continued working. Now it's back to it's old habits of mostly not working. When it began to fail again, I used one of the gallery images to test, and that worked. Back to my jpg images, not working. Again using a gallery image, a different one, and . . not working.

Since others don't seem to be able to duplicate this, one would think it's my hardware platform. But running x10.5 on that same platform, using the painting creator in it has not failed. And it's variable work/not work result is just so frustrating: like the software tosses a coin to decide 'work' or 'not work'. Probably some memory variable being used by 2 things, but variations in running (only program after a cold boot, or just started after a period of operation) have not identified what it might be. In the period under test, no updates are known to have been installed.

This sort of instability is death for an application once it becomes widely known. And even if it's fixed later, that reputation lingers on.