Page 1 of 2

failure to build an MPEG capture graph

PostPosted: Tue Sep 19, 2006 3:24 am
by Grainne_C
I've been using ULead successfully until about a week ago...all of a sudden I couldn't burn DVDs. I called HP and we reinstalled some drivers and everything was working ok....until today.

When I try to capture from my VCR I'm getting the following message:
Failed to build an MPEG capture graph or unable to connect to MPEG capture pin.
Capturing failed.
The file created is corrupt and unusable.
It will automatically be deleted.

Some of the things I've done to try to work through this:
1) I reset the capture options myself
2) I reset the capture options myself using a successful old capture
3)I captured from the tape using AVI however this was unsuccessful as the picture kept 'sticking' (so was getting the sound but not the motion).
4) I uninstalled ULead and reinstalled then rebooted the machine (PC did recognize the new hardware when rebooted).

I bought the leads and the programme in Dec 05/Jan 06 and have used it successfully many times in the past. There has been no physically 'trauma' to either the leads, the video or the PC. For all intents and purposes NOTHING has changed since I last used the programme successfully.

Any hints please?

PostPosted: Tue Sep 19, 2006 3:28 am
by Terry Stetler
First thoughts;

1. Have you run any anti-malware programs lately? Depending on their settings they can sometimes delete things they shouldn't.

2. Have you tried doing a 'Repair' installation followed by a reinstallation of all the patches?

PostPosted: Tue Sep 19, 2006 3:33 am
by Grainne_C
Thanks for the super quick response Terry!

Bear with me...I'm not hugely technical :oops:

I think by anti-malware programmes you mean something like Norten Security? if so, then yes, it scans my computer each night but I haven't had any messages from it indicating a virus or anything like that.

I didn't do a 'repair' installation...I just scrubbed the programme off the computer and reinstalled - I'll put the CD in now and see how to do a repair installation but I'm not sure how to do a reintsallation of the patches...can you explain a little on that at all?

thanks again Terry

PostPosted: Tue Sep 19, 2006 3:39 am
by Grainne_C
Ok, just did the 'repair' installation (it suspiciously only took a couple of that how long it usually takes?) and when I try to use ULead now I get the message:

Either no video capture driver is installed in this system, or no device is connected.

The computer recognised the hardware so it is definitely connected and I can even hear the soundtrack coming through the computer so I imagine that the problem is with the video capture driver...? :?

PostPosted: Tue Sep 19, 2006 3:43 am
by Terry Stetler
What capture hardware? DV cam, capture card...?

VideoStudio version?

Repairs should take longer than that.

When you did the repair did you have the VS system disc in the CD drive?

PostPosted: Tue Sep 19, 2006 3:50 am
by Grainne_C
The capture hardware consists of the Belkin package I bought which are the leads running from the VCR, through to a little plastic box (model no FS022H) then into the USB 2.0 and the mic jack of the computer.

The VS version is 6.0 (which was supplied with the leads in the Belkin package)

I put the CD in the drive, selected install driver, repair and then in about 20 seconds the computer gave me the message, 'installshield wizard has finished performing maintenance operations on hi-speed DVD creator'.

If I press the install option on that CD then (obviously) I can't get very far because the programme is already installed.

PostPosted: Tue Sep 19, 2006 4:09 am
by Grainne_C
THis is very odd...I just plugged into a different USB 2.0 port (ie not the one I've always used in the past) and now it all seems to be working! i'm so confused, I don't understand why these weird things are spontaneously happening...

PostPosted: Tue Sep 19, 2006 4:13 am
by Terry Stetler
Hmmm....old product & device (presuming one of their USB or analog devices).

My 'headbang' procedure when a repair doesn't work and when using a capture card would be to;

1. uninstall the capture cards drivers, editing package (VS-6) and reboot.

2. refresh the DirectX installation (sometimes gets messed up)

and reboot

3. reinstall the capture drivers and reboot

4. reinstall VS-6 and reboot

5. download the support & patch file archive for phased out products, VS-6 in your case, from this page (top row);

and install the patches.

Reboot and try again.

PostPosted: Tue Sep 19, 2006 4:21 am
by Ken Berry
Grainne_C -- I have long ago given up on trying to understand the whys and wherefores of USB ports. Like a lot of other people, I have 6 USB 2.0 ports on my computer, two of them on the front of the case. I have two identical external drives in identical cases. One of them I can plug into either of the front USB ports with no problem. The other will only work in one of the ports with the same cable, but if a change the cable, it will work in the other port but not the one it worked in with the other cable!

But if your set up now works on another USB port, then run with it!!! :lol: :lol:

PostPosted: Tue Sep 19, 2006 4:25 am
by Terry Stetler
Ahh....she posted that while I was writing my 'headbang' reply.


Some mb/s don't supply adequate power to all their USB ports, often due to inadequate trace widths. Others just have crappy USB support. Pick one ;)

That said I stay as far from USB capture devices as I can. Not enough bandwidth.

PostPosted: Tue Sep 19, 2006 6:08 am
by Grainne_C
Thanks all for the responses...Terry, I'll keep hold of your 'headbang' response and will use it if it happens again (at this point I'm reluctant to change anything that is now - even if only temporarily - working).

You know...I only bought the ULead package in Dec 05/Jan 06...and at that point it was brand new in the shop...I think for what I paid that it should work longer than 10 months...

PostPosted: Tue Sep 19, 2006 6:20 am
by Terry Stetler
As my post to Ken indicated it may not be the fault of VS or your hardware.

Many computer mainboards simply do not deliver adequate power to all of their USB ports, usually because the copper traces are not wide enough or some part isn't of the correct value. Not enough voltage and your capture device just won't work. When this happens the fix is simple: plug it in somewhere else.

Fact of digital life.

PostPosted: Tue Sep 19, 2006 6:22 am
by Terry Stetler
accidental double post...deleted

PostPosted: Tue Sep 19, 2006 6:33 am
by Grainne_C
the odd thing was working in that port yesterday. the port that suddendly isn't working for Ulead is working for my mp3 player.

it seems that in the past week the ULead programme has gone crazy bananas on a couple of different fronts...makes me wonder how much longer it is going to work

PostPosted: Tue Sep 19, 2006 7:58 am
by Terry Stetler
You should also consider how old a build that is; VS6 when VS10+ is current, not to mention that automatic Windows updates or any number of other things can gum up the works. Had it happen to me more than once.